summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-12 22:23:36 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-12 22:47:57 +0100
commit4fd994432f032446fbf3654ddd55c738e145e0ba (patch)
tree70090c975e2e49c883ce4564a400c05c7bd91a3c /gnu
parent061a4b68500a7aa002a89b2eea5bea8374ed905d (diff)
downloadguix-4fd994432f032446fbf3654ddd55c738e145e0ba.tar.gz
gnu: Add r-minpack-lm.
* gnu/packages/cran.scm (r-minpack-lm): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f3f964d70e..921a33fb26 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11122,3 +11122,27 @@ ranges 0 to infinity or 0 to 1, by using a @code{log} or a @code{logit}
 transformation, respectively.")
     ;; Either version of the GPL.
     (license (list license:gpl2 license:gpl3))))
+
+(define-public r-minpack-lm
+  (package
+    (name "r-minpack-lm")
+    (version "1.2-1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "minpack.lm" version))
+       (sha256
+        (base32
+         "18ym2pdql5vzngc7q5gn66d153hrfrnd8ilv8yh6vd7j7sx7vjql"))))
+    (properties `((upstream-name . "minpack.lm")))
+    (build-system r-build-system)
+    (native-inputs `(("gfortran" ,gfortran)))
+    (home-page "https://cran.r-project.org/web/packages/minpack.lm")
+    (synopsis "Levenberg-Marquardt Nonlinear Least-Squares algorithm")
+    (description
+     "The @code{nls.lm} function provides an R interface to @code{lmder} and
+@code{lmdif} from the MINPACK library, for solving nonlinear least-squares
+problems by a modification of the Levenberg-Marquardt algorithm, with support
+for lower and upper parameter bounds.  The implementation can be used via
+@rode{nls}-like calls using the @code{nlsLM} function.")
+    (license license:gpl3)))