summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2018-12-12 00:59:15 +0530
committerArun Isaac <arunisaac@systemreboot.net>2018-12-16 23:56:07 +0530
commit665f4591182bf99d2c922805892ac8f5f6181180 (patch)
tree67be4865fe34ee386c988d152aaefdb1cfc72c70 /gnu
parent04eb2645bd9390218b7ab5f8358f7942d76aa58e (diff)
downloadguix-665f4591182bf99d2c922805892ac8f5f6181180.tar.gz
gnu: emacs-circe: Enable tests.
* gnu/packages/emacs.scm (emacs-circe)[arguments]: Enable tests. Set
test-command. Add set-home phase.
[native-inputs]: Add emacs-buttercup.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 3dfc7fdafc..824aeb94d2 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -7860,6 +7860,19 @@ value of the access token.")
         (base32
          "10gi14kwxd81blddpvqh95lgmpbfgp0m955naxix3bs3r6a75n4s"))))
     (build-system emacs-build-system)
+    (arguments
+     `(#:tests? #t
+       #:test-command '("buttercup" "-L" ".")
+       #:phases
+       (modify-phases %standard-phases
+         ;; The HOME environment variable should be set to an existing
+         ;; directory for the tests to succeed.
+         (add-before 'check 'set-home
+           (lambda _
+             (setenv "HOME" "/tmp")
+             #t)))))
+    (native-inputs
+     `(("emacs-buttercup" ,emacs-buttercup)))
     ;; In order to securely connect to an IRC server using TLS, Circe requires
     ;; the GnuTLS binary.
     (propagated-inputs