summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-19 16:36:18 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:42 +0200
commit80e2694ff9d68a6553caab0e00fe57c345144eaf (patch)
tree0758736625f66808173a2a0cd5f9f9ba8be9073a /gnu
parenta04782f613b5ba7dbb02b36f26a7982be4237c24 (diff)
downloadguix-80e2694ff9d68a6553caab0e00fe57c345144eaf.tar.gz
gnu: texlive-eurosym: Fix build.
* gnu/packages/tex.scm (texlive-eurosym)[arguments]: Remove them.
[native-inputs]: Remove TEXLIVE-BIN.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm45
1 files changed, 1 insertions, 44 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b609171750..c1d6d8a001 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11923,50 +11923,7 @@ OpenType fonts.")
               "0ml24rxbl1yir4s3fjjxm0z7axklc3p33syg41b76zc7hck9mk8s")))
     (outputs '("out" "doc"))
     (build-system texlive-build-system)
-    (arguments
-     (list
-      #:modules
-      '((guix build texlive-build-system)
-        (guix build utils)
-        (srfi srfi-1)
-        (srfi srfi-26))
-      #:phases
-      #~(modify-phases %standard-phases
-          (add-before 'install 're-generate-fonts-metrics
-            (lambda _
-              (let ((mf #$(this-package-native-input "texlive-metafont"))
-                    (cm #$(this-package-native-input "texlive-cm"))
-                    (root (getcwd)))
-                (mkdir-p "build")
-                (with-directory-excursion "fonts/source/public/eurosym"
-                  ;; Tell mf where to find mf.base.
-                  (setenv "MFBASES"
-                          (string-append mf "/share/texmf-dist/web2c"))
-                  ;; Tell mf where to look for source files.
-                  (setenv "MFINPUTS"
-                          (string-append
-                           (getcwd) ":"
-                           mf "/share/texmf-dist/metafont/base:"
-                           cm "/share/texmf-dist/fonts/source/public/cm"))
-                  ;; Build font metrics (tfm).
-                  (for-each (lambda (font)
-                              (format #t "building font ~a\n" font)
-                              (invoke "mf" "-progname=mf"
-                                      (string-append "-output-directory="
-                                                     root "/build")
-                                      (string-append "\\"
-                                                     "mode:=ljfour; "
-                                                     "mag:=1; "
-                                                     "batchmode; "
-                                                     "input "
-                                                     (basename font ".mf"))))
-                            (find-files "." "[0-9]+\\.mf$")))
-                ;; Install font metrics at the appropriate location.
-                (for-each
-                 (cut install-file <> "fonts/tfm/public/eurosym")
-                 (find-files "build/" "\\.tfm$"))))))))
-    (native-inputs
-     (list texlive-bin texlive-cm texlive-metafont))
+    (native-inputs (list texlive-cm texlive-metafont))
     (home-page "https://ctan.org/pkg/eurosym")
     (synopsis "METAFONT and macros for Euro sign")
     (description