summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-08-21 15:57:01 +0100
committerChristopher Baines <mail@cbaines.net>2017-09-13 18:19:30 +0100
commit88002553ae57e8a9b0a3e1af22fc6eaf32d17567 (patch)
tree38f455d55e046f52b120e58534dc60466dc651d2 /gnu
parent3d74955842d5e6d5db531a0588e13e34bb73e6d6 (diff)
downloadguix-88002553ae57e8a9b0a3e1af22fc6eaf32d17567.tar.gz
gnu: Add perl-test-notabs.
* gnu/packages/perl.scm (perl-test-notabs): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 0627db119c..a83a896adf 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -7538,6 +7538,30 @@ with an error rather than skip.
 If used in a subtest, the remainder of the subtest will be skipped.")
     (license (package-license perl))))
 
+(define-public perl-test-notabs
+  (package
+    (name "perl-test-notabs")
+    (version "2.00")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/E/ET/ETHER/Test-NoTabs-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "127kpl1va267qar2ia4c22xb96jby2jqnda3sj5pjgmxg8si26cg"))))
+    (build-system perl-build-system)
+    (home-page
+     "http://search.cpan.org/dist/Test-NoTabs")
+    (synopsis
+     "Check the presence of tabs in your project")
+    (description
+     "@code{Test::NoTabs} lets you check the presence of tabs in your perl
+code.")
+    (license perl-license)))
+
 (define-public perl-test-nowarnings
   (package
     (name "perl-test-nowarnings")