summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-06-03 08:47:34 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-07-20 10:11:32 +0200
commit97677bbda07121887b22e12860499b6ad5fe0aa5 (patch)
tree403f265bfea0ee4cbe732f415067a4b5c07f3f6c /gnu
parentbc8c6e23683d82b5d3bba49d488356478683ffc3 (diff)
downloadguix-97677bbda07121887b22e12860499b6ad5fe0aa5.tar.gz
gnu: diffutils: Remove test-perror2 from XFAIL_TESTS on the Hurd.
* gnu/packages/base.scm (diffutils)[arguments]: When building natively on the
Hurd, Move "large-subopt" test from #:make-flags' XFAIL_TESTS to a new
'skip-tests' phase.  Remove #:make-flags for the Hurd, as "test-perror2" now
passes.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 14479c4951..1fdfaf8a57 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -303,9 +303,15 @@ differences.")
             (patches (search-patches "diffutils-fix-signal-processing.patch"))))
    (build-system gnu-build-system)
    (arguments
-    `(#:make-flags ,(if (target-hurd?)
-                        ''("XFAIL_TESTS=test-perror2 large-subopt")
-                        ''())))
+    (list
+     #:phases (if (system-hurd?)
+                  #~(modify-phases %standard-phases
+                      (add-after 'unpack 'skip-tests
+                        (lambda _
+                          (substitute* "tests/large-subopt"
+                            (("^#!.*" all)
+                             (string-append all "exit 77;\n"))))))
+                  #~%standard-phases)))
    (native-inputs (list perl))
    (synopsis "Comparing and merging files")
    (description