summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo.peng@gmail.com>2018-10-18 20:01:39 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-10-26 21:36:43 +0800
commit9886134cc6643d9353b6920b1a031cf927094d50 (patch)
tree250af687f502fa67a79ce1a34b24c45b1f63d491 /gnu
parent7e9e775f440dd38315960b681e09224b5dd4bb5d (diff)
downloadguix-9886134cc6643d9353b6920b1a031cf927094d50.tar.gz
gnu: Add qps.
* gnu/packages/lxqt.scm (qps): New variable.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lxqt.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 2a0fde4fb7..141cbaf931 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -966,6 +966,32 @@ image viewer.")
 @code{pavucontrol} of sound server @code{PulseAudio}.")
     (license license:lgpl2.1+)))
 
+(define-public qps
+  (package
+    (name "qps")
+    (version "1.10.18")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
+                           version "/" name "-" version ".tar.xz"))
+       (sha256
+        (base32 "0pzk83p7a9ax0893s9hp2qkmiilzrf8iqry5a0x1g73hdwm5hm44"))))
+    (build-system cmake-build-system)
+    (inputs
+     `(("libxrender" ,libxrender)
+       ("qtbase" ,qtbase)
+       ("qtx11extras" ,qtx11extras)))
+    (native-inputs
+     `(("qttools" ,qttools)))
+    (arguments
+     '(#:tests? #f))                    ; no tests
+    (home-page "https://lxqt.org/")
+    (synopsis "Qt-based visual process status monitor")
+    (description "@code{qps} is a monitor that displays the status of the
+processes currently in existence, much like code{top} or code{ps}.")
+    (license license:gpl2+)))
+
 (define-public qtermwidget
   (package
     (name "qtermwidget")