summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:47:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:25 +0200
commita4da766149afa50929c7cf9e4f61389fedf88780 (patch)
treea8748cdf2adc8fe297a715df6590f8c68cdb3047 /gnu
parentbac73b47bd97c4d07cc09087d41cff6b3a0b002b (diff)
downloadguix-a4da766149afa50929c7cf9e4f61389fedf88780.tar.gz
gnu: Add texlive-dowith.
* gnu/packages/tex.scm (texlive-dowith): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3d590d2f57..3d59146b6d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1590,6 +1590,28 @@ package provides a Perl program that will extract any of the sections of such
 a file, in particular providing a text'-form EPS file for use with (La)TeX.")
     (license license:artistic2.0)))
 
+(define-public texlive-dowith
+  (package
+    (name "texlive-dowith")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/dowith/"
+                   "source/generic/dowith/"
+                   "tex/generic/dowith/")
+             (base32
+              "1qlrcjac1qszgrap5v4g0d27g9k5ajqgyy493hmc9yh5wa9wmkmp")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/dowith")
+    (synopsis "Apply a command to a list of items")
+    (description
+     "The package provides macros for applying a command to all elements of
+a list without separators, and also for extending and reducing macros storing
+such lists.  Applications in mind belonged to LaTeX, but the package should
+work with other formats as well.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")