summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-10 19:51:13 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-10 21:10:10 +0200
commitaa583170dc595cf5031607792e0cecfcbebcf8b1 (patch)
tree016b6f8749aa288e6971799c74fb9769c06ea5b8 /gnu
parent9f980cdf526fa1ab3548a545340a748bc5ea8826 (diff)
downloadguix-aa583170dc595cf5031607792e0cecfcbebcf8b1.tar.gz
gnu: julia-http: Update to 0.9.17.
* gnu/packages/julia-xyz.scm (julia-http): Update to 0.9.17.
[arguments]: Skip another test in 'disable-network-tests phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 5357f7521d..6b58f2303f 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2402,7 +2402,7 @@ library for parsing HTML.")
 (define-public julia-http
   (package
     (name "julia-http")
-    (version "0.9.12")
+    (version "0.9.17")
     (source
      (origin
        (method git-fetch)
@@ -2411,7 +2411,7 @@ library for parsing HTML.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1jsyk3mhnwj4h19cxclx26igdqdrw51fd3k1hgav0nm67dy4cxyk"))))
+        (base32 "1ynzcl30sf5r42l75l5x1a8z0643hlck2kysyhag9795gzafxzv3"))))
     (build-system julia-build-system)
     (arguments
      (list
@@ -2442,6 +2442,9 @@ library for parsing HTML.")
                 (("@testset.*Body - .*" all)
                  (string-append all "return\n"))
                 (("@testset.*Write to file.*" all)
+                 (string-append all "return\n")))
+              (substitute* "test/cookies.jl"
+                (("@testset.*Set-Cookie casing.*" all)
                  (string-append all "return\n"))))))))
     (propagated-inputs
      (list julia-inifile