summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-10-15 17:11:11 -0400
committerJulien Lepiller <julien@lepiller.eu>2020-10-20 00:23:10 +0200
commitab6d077ae2bd020b122f16a07b4480bd491d6170 (patch)
tree36acea5f7c7ab774e273d2ca721f9947a82c1605 /gnu
parent7c63d0e29f3b33719a2e581d07125a9d03a0ec88 (diff)
downloadguix-ab6d077ae2bd020b122f16a07b4480bd491d6170.tar.gz
gnu: gajim-omemo: Update to 2.7.9.
* gnu/packages/messaging.scm (gajim-omemo) [version]: Update to
2.7.9.
[propagated-inputs]: Add python-axolotl-curve25519, python-cryptography
and python-qrcode.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/messaging.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 84878691c1..d1b8f1d3c1 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -859,7 +859,7 @@ and OpenPGP) and available in 29 languages.")
 (define-public gajim-omemo
   (package
     (name "gajim-omemo")
-    (version "2.7.7")
+    (version "2.7.9")
     (source
      (origin
        (method url-fetch/zipbomb)
@@ -868,7 +868,7 @@ and OpenPGP) and available in 29 languages.")
          "https://ftp.gajim.org/plugins_releases/omemo_"
          version ".zip"))
        (sha256
-        (base32 "17jl4blkq04ag3g0har6z1bmk36523d29s51g260wb1pywfb536h"))))
+        (base32 "19si2v5yrxpn2m0f684npsg0iiyl2h3r5hbxyrxv4k3acmfmhb3z"))))
     (build-system trivial-build-system)
     (arguments
      `(#:modules ((guix build utils))
@@ -882,7 +882,10 @@ and OpenPGP) and available in 29 languages.")
            (copy-recursively source share)
            #t))))
     (propagated-inputs
-     `(("python-axolotl" ,python-axolotl)))
+     `(("python-axolotl" ,python-axolotl)
+       ("python-axolotl-curve25519" ,python-axolotl-curve25519)
+       ("python-cryptography" ,python-cryptography)
+       ("python-qrcode" ,python-qrcode)))
     (synopsis "Gajim OMEMO plugin")
     (description "This package provides the Gajim OMEMO plugin.  OMEMO is an
 XMPP Extension Protocol (XEP) for secure multi-client end-to-end encryption