summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-09 19:42:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-09 19:43:43 +0200
commitb09e87be267b9d1795dcecd241bc4fdc30c3fd7a (patch)
treeabfda9d9b171038e45d8d2e03315340277bea00b /gnu
parent98e943435fc1efbc7fe6d21181d49a0936073649 (diff)
downloadguix-b09e87be267b9d1795dcecd241bc4fdc30c3fd7a.tar.gz
gnu: python-sqlalchemy: Use pyproject-build-system.
* gnu/packages/databases.scm (python-sqlalchemy)[arguments]: Replace custom
'check phase with #:test-flags.
[build-system]: Use pyproject-build-system.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/databases.scm16
1 files changed, 5 insertions, 11 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 1234594822..a0066a4fd6 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3417,7 +3417,7 @@ on localhost.")
       (uri (pypi-uri "SQLAlchemy" version))
       (sha256
        (base32 "0qzkxy47y06fqh1m7a0p7q2r9h48x9k5kl3znzhx2vj79j8l2zhp"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (native-inputs
      (list python-cython ; for C extensions
            python-pytest python-mock python-pytest-xdist)) ; for tests
@@ -3425,16 +3425,10 @@ on localhost.")
      (list python-greenlet))
     (arguments
      (list
-      #:phases
-      #~(modify-phases %standard-phases
-          (replace 'check
-            (lambda* (#:key tests? #:allow-other-keys)
-              (when tests?
-                (invoke "pytest" "-vv"
-                        "-n" (number->string (parallel-job-count))
-                        ;; The memory usage tests are very expensive and run in
-                        ;; sequence; skip them.
-                        "-k" "not test_memusage.py")))))))
+      #:test-flags
+      '(list ;; The memory usage tests are very expensive and run in sequence;
+             ;; skip them.
+             "-k" "not test_memusage.py")))
     (home-page "https://www.sqlalchemy.org")
     (synopsis "Database abstraction library")
     (description