summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-04 02:25:12 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-04 02:25:12 +0100
commitc2777bb64fabde4aef0adfcdd4db0d56faf081e4 (patch)
treee410038a2e6eafe447ca0866c45b89ffe1b27a73 /gnu
parent91aa20e2372c30549c6d2a2c31b4d6742e4dcdbd (diff)
downloadguix-c2777bb64fabde4aef0adfcdd4db0d56faf081e4.tar.gz
gnu: Rename texlive-latex-fancyvrb to texlive-fancyvrb.
* gnu/packages/tex.scm (texlive-fancyvrb): New variable, renamed from
TEXLIVE-LATEX-FANCYVRB.
(texlive-latex-fancyvrb): Deprecate variable.
* gnu/packages/docbook.scm (dblatex):
* gnu/packages/maths.scm (hypre):
* gnu/packages/python-xyz.scm (python-numpy-documentation):
(python-ipython-documentation):
(python-nbconvert):
* gnu/packages/statistics.scm (r-with-tests): Use new name.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/docbook.scm2
-rw-r--r--gnu/packages/maths.scm2
-rw-r--r--gnu/packages/python-xyz.scm6
-rw-r--r--gnu/packages/statistics.scm2
-rw-r--r--gnu/packages/tex.scm6
5 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 6af13aa1f9..c0f7dfd750 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -468,7 +468,7 @@ the in DocBook SGML DTDs.")
                                         texlive-latex-colortbl
                                         texlive-latex-fancybox
                                         texlive-fancyhdr
-                                        texlive-latex-fancyvrb
+                                        texlive-fancyvrb
                                         texlive-latex-float
                                         texlive-latex-footmisc
                                         texlive-hyperref
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4f5af57c50..e0eaffac8d 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5556,7 +5556,7 @@ set.")
                                              texlive-latex-colortbl
                                              texlive-latex-etoc
                                              texlive-fancyhdr
-                                             texlive-latex-fancyvrb
+                                             texlive-fancyvrb
                                              texlive-latex-float
                                              texlive-latex-fncychap
                                              texlive-latex-framed
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 834eaf03fb..9c120879d2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5841,7 +5841,7 @@ readable format.")
                                         texlive-etoolbox
                                         texlive-latex-expdlist
                                         texlive-fancyhdr
-                                        texlive-latex-fancyvrb
+                                        texlive-fancyvrb
                                         texlive-latex-fncychap
                                         texlive-latex-float
                                         texlive-latex-framed
@@ -8926,7 +8926,7 @@ computing.")
                                         texlive-etoolbox
                                         texlive-latex-expdlist
                                         texlive-fancyhdr
-                                        texlive-latex-fancyvrb
+                                        texlive-fancyvrb
                                         texlive-latex-fncychap
                                         texlive-latex-float
                                         texlive-latex-framed
@@ -12618,7 +12618,7 @@ time.")
                                         texlive-jknappen
                                         texlive-latex-amsmath
                                         texlive-latex-enumitem
-                                        texlive-latex-fancyvrb
+                                        texlive-fancyvrb
                                         texlive-latex-float
                                         texlive-fontspec
                                         texlive-latex-geometry
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index fbb7a594ed..bcfd3b63eb 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -351,7 +351,7 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
                                         texlive-grfext
                                         texlive-amsfonts
                                         texlive-latex-base
-                                        texlive-latex-fancyvrb
+                                        texlive-fancyvrb
                                         texlive-graphics
                                         texlive-hyperref
                                         texlive-oberdiek
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 47a20f6d90..c33f6f607f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3189,10 +3189,10 @@ users, via its Plain TeX version.)")
 
 (define-deprecated-package texlive-generic-epsf texlive-epsf)
 
-(define-public texlive-latex-fancyvrb
+(define-public texlive-fancyvrb
   (package
     (inherit (simple-texlive-package
-              "texlive-latex-fancyvrb"
+              "texlive-fancyvrb"
               (list "/doc/latex/fancyvrb/README"
                     "/tex/latex/fancyvrb/")
               (base32
@@ -3209,6 +3209,8 @@ verbatim mode; build \"example\" environments (showing both result and
 verbatim source).")
     (license license:lppl1.0+)))
 
+(define-deprecated-package texlive-latex-fancyvrb texlive-fancyvrb)
+
 (define-public texlive-graphics-def
   (package
     (inherit (simple-texlive-package