summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-03-30 12:14:29 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-02 07:41:15 -0400
commitcf86b9af53678cb4276e031957e150a98a88a664 (patch)
tree804e443e766e6fbbd28a42ddfb3648c03fafe3b2 /gnu
parent0b25557bea82d837d499c72c3de7f27c394fda33 (diff)
downloadguix-cf86b9af53678cb4276e031957e150a98a88a664.tar.gz
gnu: Add nettle-3.7.
While nettle cannot be upgraded wholesale on the master branch, we can at
least also offer the latest version available.

* gnu/packages/nettle.scm (nettle-3.5, nettle-3.7): New variables.
(nettle): Redefine as a binding to nettle-3.5, which is the current version.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/nettle.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/nettle.scm b/gnu/packages/nettle.scm
index f5e7188ff0..753e2d6e7e 100644
--- a/gnu/packages/nettle.scm
+++ b/gnu/packages/nettle.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -71,7 +72,7 @@ cryptographic toolkits for object-oriented languages or in applications
 themselves.")
     (license gpl2+)))
 
-(define-public nettle
+(define-public nettle-3.5
   ;; This version is not API-compatible with version 2.  In particular, lsh
   ;; cannot use it yet.  So keep it separate.
   (package (inherit nettle-2)
@@ -89,3 +90,17 @@ themselves.")
         ;; Build "fat" binaries where the right implementation is chosen
         ;; at run time based on CPU features (starting from 3.1.)
         `(cons "--enable-fat" ,flags))))))
+
+(define-public nettle-3.7
+  (package (inherit nettle-3.5)
+    (version "3.7.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnu/nettle/nettle-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "0qpi1qp3bcvqdsaxy2pzg530db95x8qjahkynxgwvr6dy5760ald"))))))
+
+;;; Upgrading Nettle on master would cause 10000+ packages to be rebuilt.
+(define-public nettle nettle-3.5)