summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 20:57:36 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:36 +0200
commite92dc9384ffb8384d23a90e04f1655d18036cf45 (patch)
treed5f6fb37a40b73f9fba05a7a69a65cd8e91ab0e3 /gnu
parent8418976b0f83765455603f17e55b55e9a47f6a4c (diff)
downloadguix-e92dc9384ffb8384d23a90e04f1655d18036cf45.tar.gz
gnu: texlive-pst-text: Refresh package definition.
* gnu/packages/tex.scm (texlive-pst-text): Remove SIMPLE-TEXLIVE-PACKAGE
call.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm36
1 files changed, 19 insertions, 17 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 91c0c11c5d..318d397f68 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10492,25 +10492,27 @@ or shading the cells of tables.")
       (license license:lppl1.3+))))
 
 (define-public texlive-pst-text
-  (let ((template (simple-texlive-package
-                   "texlive-pst-text"
-                   (list "/doc/generic/pst-text/"
-                         "/dvips/pst-text/pst-text.pro"
-                         "/tex/generic/pst-text/"
-                         "/tex/latex/pst-text/")
-                   (base32
-                    "146fpzd1xlqi94q5r48z8ni8qww713yh6nwkbr9pw27mjrqdadb9")
-                   #:trivial? #t)))
-    (package
-      (inherit template)
-      (propagated-inputs
-       (list texlive-pstricks))
-      (home-page "http://www.ctan.org/pkg/pst-text")
-      (synopsis "Text and character manipulation in PSTricks")
-      (description "Pst-text is a PSTricks based package for plotting text along
+  (package
+    (name "texlive-pst-text")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/pst-text/"
+                   "dvips/pst-text/"
+                   "tex/generic/pst-text/"
+                   "tex/latex/pst-text/")
+             (base32
+              "146fpzd1xlqi94q5r48z8ni8qww713yh6nwkbr9pw27mjrqdadb9")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs
+     (list texlive-pstricks))
+    (home-page "http://www.ctan.org/pkg/pst-text")
+    (synopsis "Text and character manipulation in PSTricks")
+    (description "Pst-text is a PSTricks based package for plotting text along
 a different path and manipulating characters.  It includes the functionality
 of the old package @code{pst-char}.")
-      (license license:lppl))))
+    (license license:lppl)))
 
 (define-public texlive-marginnote
   (let ((template (simple-texlive-package