summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-06 12:04:09 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-06 12:20:20 +0200
commitf711b71bd5ac7c8dca26852f9eec8461d31b73bd (patch)
tree6081ee82984ec1354184ca1388ffdbe73cea109a /gnu
parent6b61fc47e21efd5ea8e85bbf486d8ac204e4eab2 (diff)
downloadguix-f711b71bd5ac7c8dca26852f9eec8461d31b73bd.tar.gz
gnu: python2-unicodecsv: Don't use unstable tarball.
* gnu/packages/python-xyz.scm (python2-unicodecsv)[source]: Download
using git-fetch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 53244bc43a..7c1a4f85f5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9523,15 +9523,16 @@ encoding algorithms to do fuzzy string matching.")
     (name "python2-unicodecsv")
     (version "0.14.1")
     (source (origin
-             (method url-fetch)
+             (method git-fetch)
              ;; The test suite is not included in the PyPi release.
              ;; https://github.com/jdunck/python-unicodecsv/issues/19
-             (uri (string-append "https://github.com/jdunck/python-unicodecsv/"
-                                 "archive/" version ".tar.gz"))
-             (file-name (string-append name "-" version ".tar.gz"))
+             (uri (git-reference
+                    (url "https://github.com/jdunck/python-unicodecsv")
+                    (commit version)))
+             (file-name (git-file-name name version))
              (sha256
               (base32
-               "087nqanfcyp6mlfbbr5lva5f3w6iz1bybls9xlrb8icmc474wh4w"))))
+               "15hx2k41a2lpv4hcml9zp4cvlx1171mnb5s4s13xc1pxkq3vgdjy"))))
     (build-system python-build-system)
     (arguments
      `(;; It supports Python 3, but Python 3 can already do Unicode CSV.