summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 22:30:55 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:43 +0200
commitf86a0905e61c47db2655b3189311226907dccb2b (patch)
treec33a182e316bba7cf2923578d1857022bd93732c /gnu
parenta447eb3cc8fe180f2ed3bd093afdbc1351229fa0 (diff)
downloadguix-f86a0905e61c47db2655b3189311226907dccb2b.tar.gz
gnu: texlive-pict2e: Refresh package definition.
* gnu/packages/tex.scm (texlive-pict2e): Remove SIMPLE-TEXLIVE-PACKAGE
call.
[propagated-inputs]: Add TEXLIVE-GRAPHICS.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm50
1 files changed, 19 insertions, 31 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c095c0c0bd..c090a98ecf 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4882,42 +4882,30 @@ Unicode entities, and common formatting object definitions for JadeTeX.")
     (license license:lppl1.0+)))
 
 (define-public texlive-pict2e
-  (let ((template (simple-texlive-package
-                   "texlive-pict2e"
-                   (list "doc/latex/pict2e/"
-                         "source/latex/pict2e/"
-                         "tex/latex/pict2e/")
-                   (base32
-                    "0pazv1khsgjhxc673qrhjrbzlkgmcj53qccb9hw7ygdajxrjc2ba"))))
-    (package
-      (inherit template)
-      (arguments
-       (substitute-keyword-arguments (package-arguments template)
-         ((#:tex-directory _ #t) "latex/pict2e")
-         ((#:build-targets _ '()) '(list "pict2e.ins"))
-         ((#:phases phases)
-          #~(modify-phases #$phases
-              (add-after 'build 'build-doc
-                (lambda _
-                  (copy-file "p2e-drivers.dtx" "build/p2e-drivers.dtx")
-                  (with-directory-excursion "build"
-                    (invoke "pdflatex" "p2e-drivers.dtx")
-                    (delete-file "p2e-drivers.dtx")
-                    ;; texlive.tlpbd expects a "pict2e.cfg" configuration file
-                    ;; instead of "pict2e-example.cfg".  Please it.
-                    (rename-file "pict2e-example.cfg" "pict2e.cfg"))))))))
-      (home-page "https://ctan.org/pkg/pict2e")
-      (native-inputs
-       (list (texlive-updmap.cfg)))
-      (synopsis "New implementation of picture commands")
-      (description
-       "This package extends the existing LaTeX @code{picture} environment,
+  (package
+    (name "texlive-pict2e")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/pict2e/"
+                   "source/latex/pict2e/"
+                   "tex/latex/pict2e/")
+             (base32
+              "0pazv1khsgjhxc673qrhjrbzlkgmcj53qccb9hw7ygdajxrjc2ba")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs
+     (list texlive-graphics))
+    (home-page "https://ctan.org/pkg/pict2e")
+    (synopsis "New implementation of @code{picture} commands")
+    (description
+     "This package extends the existing LaTeX @code{picture} environment,
 using the familiar technique (the @code{graphics} and @code{color} packages)
 of driver files (at present, drivers for dvips, pdfTeX, LuaTeX, XeTeX, VTeX,
 dvipdfm, and dvipdfmx are available).  The package documentation has a fair
 number of examples of use, showing where things are improved by comparison
 with the LaTeX @code{picture} environment.")
-      (license license:lppl1.3+))))
+    (license license:lppl1.3+)))
 
 (define-public texlive-psnfss
   (let ((template (simple-texlive-package