summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-12-18 11:59:20 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-12-18 12:01:34 +0100
commitf90018e56821397ae28fada1c4d823c3e0c8750e (patch)
tree3bee8888327890403bb08f47af5373a96ea7f364 /gnu
parentae3f207951c75cad3966f8a2feb2faec8cc63c59 (diff)
downloadguix-f90018e56821397ae28fada1c4d823c3e0c8750e.tar.gz
gnu: Add r-ggridges.
* gnu/packages/cran.scm (r-ggridges): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c5cc759385..e0e44067aa 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1727,3 +1727,27 @@ statistics, etc.")
     (description "This package provides an implementation of scatter plots for
 plotting.  a three dimensional point cloud.")
     (license license:gpl2)))
+
+(define-public r-ggridges
+  (package
+    (name "r-ggridges")
+    (version "0.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ggridges" version))
+       (sha256
+        (base32
+         "0kfa3icqdalqdg1klxjrhfl7if35d3wnsiyl86bprw5dyqyh3lh3"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-ggplot2" ,r-ggplot2)
+       ("r-plyr" ,r-plyr)
+       ("r-scales" ,r-scales)))
+    (home-page "https://github.com/clauswilke/ggridges")
+    (synopsis "Ridgeline plots in ggplot2")
+    (description
+     "Ridgeline plots provide a convenient way of visualizing changes in
+distributions over time or space.  This package enables the creation of such
+plots in @code{ggplot2}.")
+    (license license:gpl2)))