summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-10-13 00:00:38 +0200
committerMarius Bakke <marius@gnu.org>2021-10-13 00:22:08 +0200
commitff01706675a64c1246794582bfcd703a3efb5ef2 (patch)
treeeb636edebbd38b1760c8bc96540c5670b753aaea /gnu
parentb19c51f567e63197269d6ea7534b3163bf95dd47 (diff)
downloadguix-ff01706675a64c1246794582bfcd703a3efb5ef2.tar.gz
gnu: python-zope-testrunner: Fix bytecode compilation.
* gnu/packages/python-web.scm (python-zope-testrunner)[arguments]: Delete one
test.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 38bc1df19b..5d04c2c7ac 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1992,7 +1992,15 @@ forms, HTTP servers, regular expressions, and more.")
          "0jyyf1dcz156q95x2y7yw2v420q2xn3cff0c5aci7hmdmcbn0gc7"))))
     (build-system python-build-system)
     (arguments
-     '(#:tests? #f)) ; FIXME: Tests can't find zope.interface.
+     '(#:tests? #f                    ;FIXME: Tests can't find zope.interface.
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'remove-problematic-test
+           (lambda _
+             ;; This test contains invalid syntax, which breaks bytecode
+             ;; compilation.  For simplicity just remove it.
+             (delete-file
+              "src/zope/testrunner/tests/testrunner-ex/sample2/badsyntax.py"))))))
     (native-inputs
      `(("python-zope-testing" ,python-zope-testing)))
     (propagated-inputs