summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2022-04-19 07:27:29 +0000
committerMathieu Othacehe <othacehe@gnu.org>2022-04-27 11:23:09 +0200
commit090b3823b86b6c7123527c61e7f092e641c3b7d8 (patch)
treecb8fe8942b87dbededf500e2e19600bbe92681fc /gnu
parentb840c50b3fa44b5a08708e52fb28dbbd458f5449 (diff)
downloadguix-090b3823b86b6c7123527c61e7f092e641c3b7d8.tar.gz
gnu: Add worklog.
* gnu/packages/task-management.scm (worklog): New variable.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/task-management.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/task-management.scm b/gnu/packages/task-management.scm
index 65b3dc8699..b917cbd61f 100644
--- a/gnu/packages/task-management.scm
+++ b/gnu/packages/task-management.scm
@@ -34,6 +34,7 @@
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages lua)
+  #:use-module (gnu packages ncurses)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
@@ -144,6 +145,40 @@ Done time management method.  It supports network synchronization, filtering
 and querying data, exposing task data in multiple formats to other tools.")
     (license license:expat)))
 
+(define-public worklog
+  (let ((commit "0f545ad6697ef4de7f68d92cd7cc5c6a4c60517b")
+        (revision "1"))
+    (package
+      (name "worklog")
+      (version (git-version "2.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/atsb/worklog")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "18dkmy168ks9gcnfqri1rfl0ag0dmh9d6ppfmjfcdd6g9gvi6zll"))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:make-flags
+         ,#~(list (string-append "CC=" #$(cc-for-target))
+                  (string-append "BIN=" #$output "/bin")
+                  (string-append "MAN=" #$output "/share/man"))
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'configure))
+         #:tests? #f))  ; No "check" target.
+      (inputs (list ncurses))
+      (home-page "https://github.com/atsb/worklog")
+      (synopsis "Program keeping track of time spent on different projects")
+      (description
+       "@code{worklog} is a program that helps you keep track of your time.
+@code{worklog} is a simple ncurses based based program that runs a clock and
+logs time to a logfile.")
+      (license license:public-domain))))
+
 (define-public dstask
   (package
     (name "dstask")