summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-01-08 03:42:18 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-09 02:07:16 +0100
commit161f2b1522cb5f16ed7d6574771d5edf1f12cc07 (patch)
treee307179c9d0e2e10be5581ca492e5d4ed0c8a3ac /gnu
parent517c988bcaca73a498c206d28e7b6b65f19cd54d (diff)
downloadguix-161f2b1522cb5f16ed7d6574771d5edf1f12cc07.tar.gz
gnu: Add node-debug.
* gnu/packages/node-xyz.scm (node-debug): New variable.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/node-xyz.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index b07e17d54c..f949aaa581 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -955,3 +955,45 @@ both @file{stderr} and to a timestamped file.")
 milliseconds.  A number supplied as integer or string is returned as-is, while
 a string consisting of a number and a time unit is converted to milliseconds.")
     (license license:expat)))
+
+(define-public node-debug
+  (package
+    (name "node-debug")
+    (version "4.3.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/debug-js/debug")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0ji0dmdl2xkgxqxvd6xjy7k3mmknmhvqjgc40vyly9ka1mpf20vb"))))
+    (inputs
+     (list node-ms))
+    (build-system node-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'patch-dependencies 'delete-dependencies
+           (lambda args
+             (delete-dependencies `("brfs"
+                                    "browserify"
+                                    "coveralls"
+                                    "istanbul"
+                                    "karma"
+                                    "karma-browserify"
+                                    "karma-chrome-launcher"
+                                    "karma-mocha"
+                                    "mocha"
+                                    "mocha-lcov-reporter"
+                                    "xo"
+                                    "supports-color")))))
+       #:tests? #f))
+    (home-page "https://github.com/debug-js/debug")
+    (synopsis "Debugging utility for Node.js")
+    (description "The @code{debug} module exposes a function, which if called
+with a module name as argument provides a function that writes debug output to
+@code{console.error} under that module name.  This output can be controlled in
+a more fine-grained manner by binding the @env{DEBUG} variable.")
+    (license license:expat)))