summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-06-03 08:22:13 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2017-06-04 15:41:48 +0200
commit235bc01b283915bfa479cbf2bd646f8e09dde6d7 (patch)
treef42052dd12ed7e1c40c937f1ffda06cd4ef0b723 /gnu
parent620b59eac93a90d35ed957120dee0926c9f72be4 (diff)
downloadguix-235bc01b283915bfa479cbf2bd646f8e09dde6d7.tar.gz
gnu: Add python-marshmallow.
* gnu/packages/python.scm (python-marshmallow, python2-marshmallow):
New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c2e9487e42..ef884edddb 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15171,3 +15171,31 @@ address is valid and really exists.")
 
 (define-public python2-flex
   (package-with-python2 python-flex))
+
+(define-public python-marshmallow
+  (package
+    (name "python-marshmallow")
+    (version "3.0.0b2")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (pypi-uri "marshmallow" version))
+      (sha256
+       (base32
+        "11bnpvfdbczr74177p295zbkdrax2cahvbj5bqhhlprgz2xxi5d9"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-dateutil" ,python-dateutil)
+       ("python-simplejson" ,python-simplejson)))
+    (native-inputs
+     `(("python-pytest-3.0" ,python-pytest-3.0)
+       ("python-pytz" ,python-pytz)))
+    (home-page "https://github.com/marshmallow-code/marshmallow")
+    (synopsis "Convert complex datatypes to and from native
+Python datatypes.")
+    (description "@code{marshmallow} provides a library for converting
+complex datatypes to and from native Python datatypes.")
+    (license license:expat)))
+
+(define-public python2-marshmallow
+  (package-with-python2 python-marshmallow))