summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-11-14 22:50:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-11-14 22:52:44 +0100
commit2a58ddb6da700978109f97a05157b6f9c758038c (patch)
tree18aa9d609bd9441ce873c02618ad803a2a85e92f /gnu
parenta570b4e1eef3a0efeacf2fba11257061dcf2b642 (diff)
downloadguix-2a58ddb6da700978109f97a05157b6f9c758038c.tar.gz
gnu: multipath-tools: Set prefix instead of DESTDIR.
This is necessary to avoid having multipath look for its plugins in /lib
instead of /gnu/store/...-multipath-tools-.../lib.

* gnu/packages/linux.scm (multipath-tools)[arguments]: Replace DESTDIR with
prefix in make flags; override configdir to look up stateful configurations in
global /etc directory.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 42a724b2c8..a879dcba8d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5203,7 +5203,7 @@ arrays when needed.")
      (list
       #:test-target "test"
       #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
-                           (string-append "DESTDIR=" #$output)
+                           (string-append "prefix=" #$output)
                            ;; Install Udev rules below this directory, relative
                            ;; to the prefix.
                            "SYSTEMDPATH=lib")
@@ -5218,6 +5218,8 @@ arrays when needed.")
                 (substitute* "Makefile.inc"
                   (("/bin/echo") "echo")
                   (("\\$\\(prefix\\)/usr") "$(prefix)")
+                  (("configdir.*:= \\$\\(prefix\\)/etc/multipath/conf.d")
+                   "configdir := /etc/multipath/conf.d")
                   ;; Do not save timestamp to avoid gzip "timestamp
                   ;; out-of-range" warnings.
                   (("gzip -9") "gzip -9n"))