summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-10-07 19:48:40 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-10-08 01:22:28 +0200
commit2da9ceaeb92e768876f92bfb3374d04d5851e3a4 (patch)
treef1daddadef7366e610b3f7a56d32e645df2b6b27 /gnu
parent91334d36a45f80b4d7773498b8f23ba137404f36 (diff)
downloadguix-2da9ceaeb92e768876f92bfb3374d04d5851e3a4.tar.gz
gnu: Add font-google-noto-serif-cjk.
* gnu/packages/fonts.scm (font-google-noto-serif-cjk): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fonts.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 43e23094ad..3ca4874fd9 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -940,6 +940,28 @@ display all Unicode symbols.  This package provides the Sans Serif variant of
 CJK fonts.")
     (license license:silofl1.1)))
 
+(define-public font-google-noto-serif-cjk
+  (package
+    (name "font-google-noto-serif-cjk")
+    (version "2.001")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/googlefonts/noto-cjk/releases/download/Serif"
+             version "/04_NotoSerifCJKOTC.zip"))
+       (file-name (string-append name "-" version ".zip"))
+       (sha256
+        (base32 "1l6r3sz2s0vcyfx6ria7wqcq45zp40gxgg97lh8hpmajhzw301ig"))))
+    (build-system font-build-system)
+    (home-page "https://www.google.com/get/noto/")
+    (synopsis "Fonts to cover all languages")
+    (description "Google Noto Fonts is a family of fonts designed to support
+all languages with a consistent look and aesthetic.  Its goal is to properly
+display all Unicode symbols.  This package provides the Serif variant of CJK
+fonts.")
+    (license license:silofl1.1)))
+
 (define-public font-google-roboto
   (package
     (name "font-google-roboto")