summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-06-28 16:33:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-06-29 14:27:22 +0200
commit3a8bfebed94ba295432da8304b7ffb4a611ef761 (patch)
treed2f2fe3214de0a36d5ebddbd2ab51540a0d19358 /gnu
parent70d6ec3e4facb2eed4b8842031ebd2683a8cfd3b (diff)
downloadguix-3a8bfebed94ba295432da8304b7ffb4a611ef761.tar.gz
etc: Remove hydra.gnu.org.pub key.
* etc/substitutes/hydra.gnu.org.pub: Delete file.
* guix/self.scm (miscellaneous-files): Don't install it.
* Makefile.am (dist_pkgdata_DATA): Remove it.
* gnu/services/base.scm (%default-authorized-guix-keys): Likewise.
(hydra-key-authorization): Rename to…
(substitute-key-authorization): …this.  Adjust only call site.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/services/base.scm7
-rw-r--r--gnu/system/install.scm4
2 files changed, 5 insertions, 6 deletions
diff --git a/gnu/services/base.scm b/gnu/services/base.scm
index 3c1827fb70..537d30add5 100644
--- a/gnu/services/base.scm
+++ b/gnu/services/base.scm
@@ -1533,7 +1533,7 @@ GID."
     (('gnu rest ...) #t)
     (rest #f)))
 
-(define (hydra-key-authorization keys guix)
+(define (substitute-key-authorization keys guix)
   "Return a gexp with code to register KEYS, a list of files containing 'guix
 archive' public keys, with GUIX."
   (define default-acl
@@ -1570,8 +1570,7 @@ archive' public keys, with GUIX."
 
 (define %default-authorized-guix-keys
   ;; List of authorized substitute keys.
-  (list (file-append guix "/share/guix/hydra.gnu.org.pub")
-        (file-append guix "/share/guix/berlin.guixsd.org.pub")))
+  (list (file-append guix "/share/guix/berlin.guixsd.org.pub")))
 
 (define-record-type* <guix-configuration>
   guix-configuration make-guix-configuration
@@ -1688,7 +1687,7 @@ archive' public keys, with GUIX."
 
      ;; Optionally authorize substitute server keys.
      (if authorize-key?
-         (hydra-key-authorization keys guix)
+         (substitute-key-authorization keys guix)
          #~#f))))
 
 (define* (references-file item #:optional (name "references"))
diff --git a/gnu/system/install.scm b/gnu/system/install.scm
index 453b0bdd6d..912096027f 100644
--- a/gnu/system/install.scm
+++ b/gnu/system/install.scm
@@ -330,8 +330,8 @@ Access documentation at any time by pressing Alt-F2.\x1b[0m
           ;; The usual services.
           (syslog-service)
 
-          ;; The build daemon.  Register the hydra.gnu.org key as trusted.
-          ;; This allows the installation process to use substitutes by
+          ;; The build daemon.  Register the default substitute server key(s)
+          ;; as trusted to allow the installation process to use substitutes by
           ;; default.
           (service guix-service-type
                    (guix-configuration (authorize-key? #t)))