summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-10-13 13:40:03 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-10-27 13:25:15 +0200
commit447400c85321f2d246c82b861e9f159fe2a84cef (patch)
treeb26d515123f7a96ee72b929a3dc844eacd901924 /gnu
parentd748d4fd6cdeb3410a6b9dc325e4769bec25fe1a (diff)
downloadguix-447400c85321f2d246c82b861e9f159fe2a84cef.tar.gz
gnu: Add python-markdown-it-py.
* gnu/packages/python-xyz.scm (python-markdown-it-py): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d352e879f4..d1787c3667 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4097,6 +4097,45 @@ modules.  It creates a special virtual environment such that @command{pip} or
 work on your part.")
     (license license:expat)))
 
+(define-public python-markdown-it-py
+  (package
+    (name "python-markdown-it-py")
+    (version "2.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "markdown-it-py" version))
+              (sha256
+               (base32
+                "1nh75i72584r70alhqc479gys04s5m5g3vq601yf2njbs7z5jzng"))))
+    (build-system python-build-system)
+    (arguments
+     (list
+      #:tests? #f                       ;pypi source does not contains tests
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'build
+            (lambda _ (invoke "flit" "build")))
+          (replace 'install
+            (lambda* (#:key inputs outputs #:allow-other-keys)
+              (add-installed-pythonpath inputs outputs)
+              (for-each
+               (lambda (wheel)
+                 (invoke "python" "-m" "pip" "install"
+                         wheel (string-append "--prefix=" #$output)))
+               (find-files "dist" "\\.whl$")))))))
+    (native-inputs (list python-flit))
+    (propagated-inputs
+     (list python-mdurl
+           python-typing-extensions))
+    (home-page "https://github.com/executablebooks/markdown-it-py")
+    (synopsis "Python port of markdown-it")
+    (description
+     "This is a Python port of @code{markdown-it}, and some of its associated
+plugins.  The driving design philosophy of the port has been to change as
+little of the fundamental code structure (file names, function name, etc) as
+possible.")
+    (license license:expat)))
+
 (define-public python-markupsafe
   (package
     (name "python-markupsafe")