summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-12-05 17:30:02 +0100
committerKei Kebreau <kkebreau@posteo.net>2019-06-20 23:24:37 -0400
commit5120f24f0eec81d44754f0bcc645d3aa06d31e3d (patch)
treedf955ff3e3524206ed755b61672194568be2e587 /gnu
parentb74ef0bae75525227de092c4844b920625095f65 (diff)
downloadguix-5120f24f0eec81d44754f0bcc645d3aa06d31e3d.tar.gz
gnu: gnome-keyring: Add missing input.
* gnu/packages/gnome.scm (gnome-keyring)[native-inputs]: Add glib.
[arguments]: Move "fix-docbook" phase after "unpack" phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm38
1 files changed, 19 insertions, 19 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 787d9ab074..ff102d40ee 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -705,25 +705,24 @@ GNOME Desktop.")
              (substitute* "po/Makefile.in.in"
                (("/bin/sh") (which "sh")))
              #t))
-         (add-before
-          'configure 'fix-docbook
-          (lambda* (#:key inputs #:allow-other-keys)
-            (substitute* "docs/Makefile.am"
-              (("http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl")
-               (string-append (assoc-ref inputs "docbook-xsl")
-                              "/xml/xsl/docbook-xsl-"
-                              ,(package-version docbook-xsl)
-                              "/manpages/docbook.xsl")))
-            (setenv "XML_CATALOG_FILES"
-                    (string-append (assoc-ref inputs "docbook-xml")
-                                   "/xml/dtd/docbook/catalog.xml"))
-            ;; Rerun the whole thing to avoid version mismatch ("This is
-            ;; Automake 1.15.1, but the definition used by this
-            ;; AM_INIT_AUTOMAKE comes from Automake 1.15.").  Note: we don't
-            ;; use 'autoreconf' because it insists on running 'libtoolize'.
-            (invoke "autoconf")
-            (invoke "aclocal")
-            (invoke "automake" "-ac"))))))
+         (add-after 'unpack 'fix-docbook
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "docs/Makefile.am"
+               (("http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl")
+                (string-append (assoc-ref inputs "docbook-xsl")
+                               "/xml/xsl/docbook-xsl-"
+                               ,(package-version docbook-xsl)
+                               "/manpages/docbook.xsl")))
+             (setenv "XML_CATALOG_FILES"
+                     (string-append (assoc-ref inputs "docbook-xml")
+                                    "/xml/dtd/docbook/catalog.xml"))
+             ;; Rerun the whole thing to avoid version mismatch ("This is
+             ;; Automake 1.15.1, but the definition used by this
+             ;; AM_INIT_AUTOMAKE comes from Automake 1.15.").  Note: we don't
+             ;; use 'autoreconf' because it insists on running 'libtoolize'.
+             (invoke "autoconf")
+             (invoke "aclocal")
+             (invoke "automake" "-ac"))))))
     (inputs
      `(("libgcrypt" ,libgcrypt)
        ("linux-pam" ,linux-pam)
@@ -733,6 +732,7 @@ GNOME Desktop.")
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("glib" ,glib "bin")
+       ("glib" ,glib) ; for m4 macros
        ("python" ,python-2) ;for tests
        ("intltool" ,intltool)
        ("autoconf" ,autoconf)