summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-02-21 20:56:45 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-02-21 21:15:06 +0200
commit64465558765e7d48b531cacfcf1e5f28d8eb2a5f (patch)
tree4160e62271f10f750c43993f9edd61865e84575b /gnu
parentfd61591850f493f1aff6b8cfb7eb8ea8c3d82d1f (diff)
downloadguix-64465558765e7d48b531cacfcf1e5f28d8eb2a5f.tar.gz
gnu: aalib: Support aarch64.
* gnu/packages/video.scm (aalib)[arguments]: Modify custom configure
phase to declare host type on aarch64.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 7eff842e0d..c61b372af7 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -136,6 +136,11 @@
                                                       (%current-system))
                                             '("--host=mips64el-unknown-linux-gnu")
                                             '())
+                                      ;; The same is also true with aarch64.
+                                      ,@(if (string=? "aarch64-linux"
+                                                      (%current-system))
+                                            '("--host=aarch64-unknown-linux-gnu")
+                                            '())
                                       (string-append "--with-ncurses="
                                                      ncurses)))))))))
     (home-page "http://aa-project.sourceforge.net/aalib/")