summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-11-07 19:47:44 +0000
committerLudovic Courtès <ludo@gnu.org>2022-11-11 23:17:44 +0100
commit688c3ef28220979e79ffd061c762bda84a663534 (patch)
tree09b69f1b32ddba26ed3d5ec13d8cba3bbff75a17 /gnu
parent159bf4ac24fb2fbdad51619aa8784e0e8154d6cc (diff)
downloadguix-688c3ef28220979e79ffd061c762bda84a663534.tar.gz
gnu: spdlog: Update to 1.11.0.
* gnu/packages/logging.scm (spdlog): Update to 1.11.0.
[source]<origin>: Remove obselete snippet.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/logging.scm11
1 files changed, 2 insertions, 9 deletions
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 7cce8e1624..58af70c7c5 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -212,7 +212,7 @@ output in multiple windows in a terminal.")
 (define-public spdlog
   (package
     (name "spdlog")
-    (version "1.10.0")
+    (version "1.11.0")
     (source
      (origin
        (method git-fetch)
@@ -221,14 +221,7 @@ output in multiple windows in a terminal.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "02xz017ba9fssm1rp1fcfld7h79awbr6fqai9dxaqp02akp3davk"))
-       (modules '((guix build utils)))
-       (snippet
-        ;; Prevent race on busy hardware.  Remove snippet for versions
-        ;; > 1.10.0; see <https://github.com/gabime/spdlog/issues/2363>.
-        '(substitute* "tests/test_misc.cpp"
-           (("spdlog::details::os::sleep_for_millis\\(10\\)")
-            "spdlog::details::os::sleep_for_millis(100)")))))
+        (base32 "0i3a1cqrg1sz0w50g7zz9x73rf838igqri12q8ijh4rzpq0qq3ch"))))
     (build-system cmake-build-system)
     ;; TODO run benchmark. Currently not possible, as adding
     ;; (gnu packages benchmark) forms a dependency cycle