summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-12-22 14:24:30 +0100
committerMarius Bakke <marius@gnu.org>2022-12-22 16:50:47 +0100
commit9279775d6904830b8ffa0bf7bf06e0904aeca323 (patch)
tree3485de62b72761aeed213503e7755a63bb10fc14 /gnu
parent209aed9511f41b2bfabe32d2e280192e64e3d54b (diff)
downloadguix-9279775d6904830b8ffa0bf7bf06e0904aeca323.tar.gz
gnu: iPXE: Embed the actual package version.
* gnu/packages/bootloaders.scm (ipxe)[arguments]: Add phase to set the proper
version.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bootloaders.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 7c4c92ad9d..464a6f54c1 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -1419,7 +1419,7 @@ order to add a suitable bootloader menu entry.")
   ;;
   ;; TODO: Bump this timestamp at each modifications of the package (not only
   ;; for updates) by running: date +%s.
-  (let ((timestamp "1591706427"))
+  (let ((timestamp "1671715380"))
     (package
       (name "ipxe")
       (version "1.21.1")
@@ -1481,6 +1481,14 @@ order to add a suitable bootloader menu entry.")
          (modify-phases %standard-phases
            (add-after 'unpack 'enter-source-directory
              (lambda _ (chdir "src") #t))
+           (add-after 'enter-source-directory 'set-version
+             (lambda _
+               ;; When not building from a git checkout, iPXE encodes the
+               ;; version as "1.0.0+".  Use the package version instead.
+               (substitute* "Makefile"
+                 (("^VERSION[[:blank:]]+=.*")
+                  (string-append "VERSION = " ,(package-version this-package)
+                                 "-guix\n")))))
            (add-after 'enter-source-directory 'set-options
              (lambda _
                (substitute* "config/general.h"