summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 12:59:26 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:22 -0500
commitab761e9dd845b72b0a2e6bd8d2b1af0fa82fde99 (patch)
tree328986e4ea1d5b5508660b5f1de38b3ab98ba14d /gnu
parent03b0c92e2a75c73204791fa28858e0de21856c14 (diff)
downloadguix-ab761e9dd845b72b0a2e6bd8d2b1af0fa82fde99.tar.gz
gnu: ghc-socks: Update to 0.6.1.
* gnu/packages/haskell-xyz.scm (ghc-socks): Update to 0.6.1.
[inputs]: Add 'ghc-basement'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-xyz.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index cfc5f05c35..8a85ffd9f4 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -9380,17 +9380,18 @@ automatically by SmallCheck.")
 (define-public ghc-socks
   (package
     (name "ghc-socks")
-    (version "0.5.6")
+    (version "0.6.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://hackage.haskell.org/package/"
                                   "socks/socks-" version ".tar.gz"))
               (sha256
                (base32
-                "0f44qy74i0n6ll3jym0a2ipafkpw1h67amcpqmj8iq95h21wsqzs"))))
+                "0wvaxy3dkv97wrncjv1rxrmjr4014hgxz82kixvcwqdhidalfi3k"))))
     (build-system haskell-build-system)
     (inputs
      `(("ghc-cereal" ,ghc-cereal)
+       ("ghc-basement" ,ghc-basement)
        ("ghc-network" ,ghc-network)))
     (home-page "https://github.com/vincenthz/hs-socks")
     (synopsis "SOCKS proxy (version 5) implementation")