summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-09-22 19:53:12 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-09-23 18:17:16 +0200
commitbea4a3abec0d039274547e5284fbfc5276bd87f4 (patch)
tree057866ededa0df421f7e472f1562cdda26213820 /gnu
parent31a3c9b441e7d59bf56db7467a9d196178abbfca (diff)
downloadguix-bea4a3abec0d039274547e5284fbfc5276bd87f4.tar.gz
gnu: xfsprogs: Build verbosely.
* gnu/packages/linux.scm (xfsprogs)[arguments]: Add "V=1"
to #:make-flags, and honour them in custom phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index fdc5cb7c8d..b3354d1100 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7700,6 +7700,8 @@ compatible with Python's ConfigParser style of .INI files, including RFC
     (outputs (list "out" "python"))
     (arguments
      `(#:tests? #f   ; kernel/user integration tests are in package "xfstests"
+       #:make-flags
+       (list "V=1")
        #:phases
        (modify-phases %standard-phases
          (add-after 'install 'separate-python-output
@@ -7713,8 +7715,8 @@ compatible with Python's ConfigParser style of .INI files, including RFC
                                (string-append python script)))
                 (list "/sbin/xfs_scrub_all")))))
          (add-after 'install 'install-headers
-           (lambda _
-             (invoke "make" "install-dev"))))))
+           (lambda* (#:key make-flags #:allow-other-keys)
+             (apply invoke "make" "install-dev" make-flags))))))
     (native-inputs
      `(("gettext" ,gettext-minimal)))
     (inputs