summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-04-21 22:29:39 +0200
committerLudovic Courtès <ludo@gnu.org>2023-04-21 23:01:18 +0200
commitcbf169608c223cdfb8bbd62f82129d5c674ef0a6 (patch)
tree45d5ffd1b0a389f0441c1971ab640024faf4a986 /gnu
parent5c26e06efa38f82957154a3f0e29c27e04615542 (diff)
downloadguix-cbf169608c223cdfb8bbd62f82129d5c674ef0a6.tar.gz
gnu: python-afdko: Add version 3.6.1.
* gnu/packages/fontutils.scm (python-afdko-3.6.1): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fontutils.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index b32d76c15a..3b119a21ec 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -336,6 +336,42 @@ but also provides many useful font conversion and analysis facilities.
 @end table")
     (license license:asl2.0)))
 
+(define-public python-afdko-3.6.1
+  ;; This older version does not depend on Java and Antlr4.
+  (package
+    (inherit python-afdko)
+    (version "3.6.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "afdko" version))
+       (sha256
+        (base32 "0187xhgw6spzaji93fs1mnhqnq30pxhdj1p2m88673szvzpf10av"))))
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'build 'set-CC
+                 (lambda _
+                   (setenv "CC" "gcc"))))))
+    (native-inputs
+     (list pkg-config
+           python-pytest
+           python-setuptools-scm
+           python-wheel))
+    (inputs
+     (list bash-minimal
+           libxml2))
+    (propagated-inputs
+     (list psautohint
+           python-booleanoperations
+           python-defcon
+           python-fontmath
+           python-fonttools
+           python-lxml
+           python-tqdm
+           python-ufonormalizer
+           python-ufoprocessor))))
+
 (define-public python-cffsubr
   (package
     (name "python-cffsubr")