summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-10 23:07:50 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-10 23:07:50 +0300
commitd7827c941eb057b04453341d9d5756500dee6421 (patch)
treecab0cee9bbc798935c45db37cf42356b2ceb752a /gnu
parente4e51dcd7642ddf89ed84ec6f285270e41ce9df3 (diff)
downloadguix-d7827c941eb057b04453341d9d5756500dee6421.tar.gz
gnu: Add rust-clang-ast-test-suite-0.0.0.
* ngu/packages/crates-io.scm (rust-clang-ast-test-suite-0.0.0): New
variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 91faf341c6..e7f3aa7eb2 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -7289,6 +7289,28 @@ coding.")
      "This package provides current CI environment information.")
     (license license:asl2.0)))
 
+(define-public rust-clang-ast-test-suite-0.0.0
+  (package
+    (name "rust-clang-ast-test-suite")
+    (version "0.0.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "clang-ast-test-suite" version))
+        (file-name
+         (string-append name "-" version ".tar.gz"))
+        (sha256
+         (base32
+          "04c6p67w2f3s74pl83swj93l6p9g88vgki0rp2vxbb0bzm1hqy5h"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t))   ; Not intended to be built independently.
+    (home-page "https://github.com/dtolnay/clang-ast")
+    (synopsis "Test suite of the clang-ast crate")
+    (description
+     "This package contains the test suite of the @code{clang-ast} crate.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-clang-sys-1
   (package
     (name "rust-clang-sys")