summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorYovan Naumovski <yovan@gorski.stream>2023-04-05 22:01:41 +0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-04-08 14:04:45 +0200
commitdadb11c85d075f11219183b00681efd329fc78dc (patch)
tree26a68b5bf7d7609df351991d1b30b2d30eda8e34 /gnu
parentc47694f116b98ce44fce37bd0f7458b9756658e5 (diff)
downloadguix-dadb11c85d075f11219183b00681efd329fc78dc.tar.gz
gnu: ruby-pg: Update to 1.4.6.
* gnu/packages/ruby.scm (ruby-pg): Update to 1.4.6.
[arguments]: Remove DISABLE-FAILING-TESTS phase, the tests pass without it.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm16
1 files changed, 3 insertions, 13 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 3bf0f0f534..203b5754ff 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7798,7 +7798,7 @@ alternative to Marshal for Object serialization.")
 (define-public ruby-pg
   (package
     (name "ruby-pg")
-    (version "1.3.5")
+    (version "1.4.6")
     (home-page "https://github.com/ged/ruby-pg")
     (source
      (origin
@@ -7809,23 +7809,13 @@ alternative to Marshal for Object serialization.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0c2k2cibd5wwdhva68j5hhfpybm3wmvn2ym4ppn5mqmddwkjkvnk"))))
+         "0k7jgx7x7p6gbsbrv2l5rq27nff2nphnls1sdq525d82b068qnfm"))))
     (build-system ruby-build-system)
     (arguments
      (list
       #:test-target "spec"
       #:phases
       #~(modify-phases %standard-phases
-          (add-after 'unpack 'disable-failing-tests
-            (lambda _
-              ;; These tests fail because DNS is unavailable, giving an
-              ;; unexpected fallback executable in the connection string.
-              (substitute* "spec/pg/connection_spec.rb"
-                (("it (\"accepts an URI and adds( proper)? hostaddr\")" test)
-                 (string-append "xit " test))
-                (("it \"can create a connection option string from an option\
- string and a hash\"" test)
-                 (string-append "xit " test)))))
                (add-before 'build 'compile
                  (lambda _
                    (invoke "rake" "compile")))
@@ -7847,7 +7837,7 @@ alternative to Marshal for Object serialization.")
      (list postgresql))
     (synopsis "Ruby interface to PostgreSQL")
     (description "Pg is the Ruby interface to the PostgreSQL RDBMS.  It works
-with PostgreSQL 9.0 and later.")
+with PostgreSQL 9.3 and later.")
     (license license:ruby)))
 
 (define-public ruby-byebug