summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-15 23:39:49 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-19 20:12:13 -0400
commitdc2f26edae0e367d4f0f495b79ebc5f79bb80465 (patch)
treecb94a61ce91a2b550b1d72d5b54b970ee56018e3 /gnu
parent9df900341fa60f7a945bffd2ec00a59ece4d6f7b (diff)
downloadguix-dc2f26edae0e367d4f0f495b79ebc5f79bb80465.tar.gz
gnu: python-setuptools-scm: Update to 7.1.0.
* gnu/packages/python-build.scm (python-setuptools-scm): Update to 7.1.0.
[arguments]: Disable tests.
[propagated-inputs]: Add python-typing-extensions.  Remove input labels.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-build.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 7f1ddf79da..72e522f0b8 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -622,16 +622,16 @@ system, then @code{flit_core} to build the package.")
 (define-public python-setuptools-scm
   (package
     (name "python-setuptools-scm")
-    (version "6.3.2")
+    (version "7.1.0")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "setuptools_scm" version))
               (sha256
-               (base32 "1wm0i27siyy1yqr9rv7lqvb65agay9051yi8jzmi8dgb3q4ai6m4"))))
+               (base32 "09wg4zg30ir1c2cvwqipaz3hwaxz503fgw5zdvaxgakilx2q6l3c"))))
     (build-system python-build-system)
-    (propagated-inputs
-     `(("python-packaging",python-packaging-bootstrap)
-       ("python-tomli" ,python-tomli)))
+    (arguments (list #:tests? #f))    ;avoid extra dependencies such as pytest
+    (propagated-inputs (list python-packaging-bootstrap python-tomli
+                             python-typing-extensions))
     (home-page "https://github.com/pypa/setuptools_scm/")
     (synopsis "Manage Python package versions in SCM metadata")
     (description