summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-12-12 17:10:46 -0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-12-12 21:50:41 +0100
commite1da617a2037fd3eae073f1e0b8c28d8f8a49469 (patch)
tree78bbed683099dd6066894671ce53640cce743df3 /gnu
parente799da33ee069e3b6ade08eb72a09499742155f8 (diff)
downloadguix-e1da617a2037fd3eae073f1e0b8c28d8f8a49469.tar.gz
gnu: libredwg: Update to 0.11.1.
* gnu/packages/engineering.scm (libredwg): Update to 0.11.1.
[native-inputs]: Change python to python-wrapper, add perl.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/engineering.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index e436994492..7eb8bbf893 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1133,22 +1133,23 @@ use on a given system.")
 (define-public libredwg
   (package
     (name "libredwg")
-    (version "0.11")
+    (version "0.11.1")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://gnu/libredwg/libredwg-"
              version ".tar.xz"))
        (sha256
-        (base32 "1vd7ii32k5447z7k4w9s005hv1ffpj6dyf1w40x6c53qksrblny2"))))
+        (base32 "1xx6y6ckm4mzqln8y8lqf5frcn2b32ypc0d0h9dzpz6363zh7pdn"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags '("--disable-bindings")))
     (native-inputs
      `(("libxml2" ,libxml2)
        ("parallel" ,parallel)
+       ("perl" ,perl)
        ("pkg-config" ,pkg-config)
-       ("python" ,python)
+       ("python" ,python-wrapper)
        ("python-libxml2" ,python-libxml2)))
     (inputs
      `(("pcre2" ,pcre2)))