summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-11-01 00:13:26 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-11-01 00:13:55 +0100
commitf3d5d572debe59839afe29683965c6df39cb782c (patch)
treec1b287492af8c0501fd8545c90be3b852dff2905 /gnu
parent1872c00df50d64c82172a25276a0fa5334922931 (diff)
downloadguix-f3d5d572debe59839afe29683965c6df39cb782c.tar.gz
gnu: binwalk: Update to 2.3.2.
* gnu/packages/python-xyz.scm (binwalk): Update to 2.3.2.
[arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2793b25f07..32d6b403d4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16443,7 +16443,7 @@ binary or text.")
 (define-public binwalk
   (package
     (name "binwalk")
-    (version "2.2.0")
+    (version "2.3.2")
     (source
      (origin
        (method git-fetch)
@@ -16452,8 +16452,7 @@ binary or text.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32
-         "1bxgj569fzwv6jhcbl864nmlsi9x1k1r20aywjxc8b9b1zgqrlvc"))))
+        (base32 "01dalxw07c42ka4fqpixcacvy42h04ya909lzpmsblr9s2xdgwcm"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -16464,8 +16463,7 @@ binary or text.")
                      (string-append
                       (getcwd) "/src/"
                       ":" (getenv "PYTHONPATH")))
-             (setenv "HOME" "")
-             #t)))))
+             (setenv "HOME" ""))))))
     (native-inputs
      `(("python-coverage" ,python-coverage)
        ("python-nose" ,python-nose)))