summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-04 18:41:20 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-04 19:54:27 +0100
commitf41576c09f79f9ce14ed8aa7fb044c1b8fc6a28d (patch)
tree562c5ef19896467264269eb8d15510d689738157 /gnu
parentf33e490334de6347c4069d532474cf76229a242b (diff)
downloadguix-f41576c09f79f9ce14ed8aa7fb044c1b8fc6a28d.tar.gz
gnu: sra-tools: Remove references to %build-inputs.
* gnu/packages/bioinformatics.scm (sra-tools)[arguments]: Use a gexp instead
of referencing %build-inputs.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm26
1 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index cb2fb05633..8b3f1af379 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -6956,19 +6956,19 @@ sequence itself can be retrieved from these databases.")
      `(#:parallel-build? #f             ; not supported
        #:tests? #f                      ; no "check" target
        #:make-flags
-       (list (string-append "DEFAULT_CRT="
-                            (assoc-ref %build-inputs "ncbi-vdb")
-                            "/kfg/certs.kfg")
-             (string-append "DEFAULT_KFG="
-                            (assoc-ref %build-inputs "ncbi-vdb")
-                            "/kfg/default.kfg")
-             (string-append "VDB_LIBDIR="
-                            (assoc-ref %build-inputs "ncbi-vdb")
-                            ,(if (string-prefix? "x86_64"
-                                                 (or (%current-target-system)
-                                                     (%current-system)))
-                                 "/lib64"
-                                 "/lib32")))
+       ,#~(list (string-append "DEFAULT_CRT="
+                               #$(this-package-input "ncbi-vdb")
+                               "/kfg/certs.kfg")
+                (string-append "DEFAULT_KFG="
+                               #$(this-package-input "ncbi-vdb")
+                               "/kfg/default.kfg")
+                (string-append "VDB_LIBDIR="
+                               #$(this-package-input "ncbi-vdb")
+                               #$(if (string-prefix? "x86_64"
+                                                     (or (%current-target-system)
+                                                         (%current-system)))
+                                     "/lib64"
+                                     "/lib32")))
        #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'set-perl-search-path