summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBrett Gilio <brettg@posteo.net>2018-11-10 15:04:51 -0600
committerArun Isaac <arunisaac@systemreboot.net>2020-12-11 13:00:54 +0530
commitf765577dec0340d035021d030f17b54a3a5fd6b1 (patch)
treec022d6e1994716b8bff3f4da094659151383c2a6 /gnu
parent72e3614666b8ffb7ecc568cbf4ba18874b9d8750 (diff)
downloadguix-f765577dec0340d035021d030f17b54a3a5fd6b1.tar.gz
gnu: Add emacs-webpaste.
* gnu/packages/emacs-xyz.com (emacs-webpaste): New variable.

Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1f6deb75e4..2318027c58 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25837,3 +25837,44 @@ windows' layout, and their buffers.")
 between cursor and next word, parenthesis or delimiter while honoring some
 rules about where space should be left to separate words and parentheses.")
       (license license:gpl2+))))
+
+(define-public emacs-webpaste
+  (package
+    (name "emacs-webpaste")
+    (version "3.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/etu/webpaste.el")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "08545ihkzflw80rwklnxiswrpdrl8kr74xzxm5wsgrf36fkj9rn2"))))
+    (build-system emacs-build-system)
+    (arguments
+     `(#:tests? #t
+       #:test-command '("make" "unit" "integration")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-tests
+           (lambda _
+             ;; Do not use cask to run tests.
+             (substitute* "Makefile"
+               (("\\$\\{CASK\\} exec ") ""))
+             ;; Disable tests that need network access.
+             (substitute* (list "tests/unit/test-webpaste-provider-creation.el"
+                                "tests/integration/test-webpaste-providers.el")
+               (("describe") "xdescribe")))))))
+    (native-inputs
+     `(("emacs-buttercup" ,emacs-buttercup)))
+    (propagated-inputs
+     `(("emacs-request" ,emacs-request)))
+    (home-page "https://github.com/etu/webpaste.el")
+    (synopsis "Paste to pastebin-like services")
+    (description "This mode allows to paste whole buffers or parts of buffers
+to pastebin-like services.  It supports more than one service and will
+failover if one service fails.  More services can easily be added over time
+and prefered services can easily be configured.")
+    (license license:gpl3+)))