summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2022-12-16 13:25:27 +0000
committerJulien Lepiller <julien@lepiller.eu>2022-12-21 22:10:42 +0100
commitfe5836feaf61a7758c2291d9f665b227de3fa9b7 (patch)
treebf5d18932a6eaed16a085cd63ee94f0664b4517b /gnu
parent8ed74a17870839513539b884bf203a0b52bc5a9c (diff)
downloadguix-fe5836feaf61a7758c2291d9f665b227de3fa9b7.tar.gz
gnu: Add ocaml5.0-merlin.
* gnu/packages/ocaml.scm (ocaml5.0-merlin): New variable.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c986a9f354..94b4fd514e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5449,6 +5449,7 @@ interfaces and the standard higher-level merlin protocol.")
              (when tests?
                (invoke "dune" "runtest" "-p" "merlin,dot-merlin-reader")))))))
     (propagated-inputs (list ocaml-merlin-lib ocaml-yojson))
+    (properties `((ocaml5.0-variant . ,(delay ocaml5.0-merlin))))
     (native-inputs
      (list ocaml-dot-merlin-reader ; required for tests
            ocaml-ppxlib
@@ -5461,6 +5462,32 @@ External contributors added support for Visual Studio Code, Sublime Text and
 Atom.")
     (license license:expat)))
 
+(define-public ocaml5.0-merlin
+  (package-with-ocaml5.0
+   (package
+     (inherit ocaml-merlin-lib-500)
+     (name "ocaml-merlin")
+     (arguments
+      '(#:package "merlin"
+        #:phases
+        (modify-phases %standard-phases
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (invoke "dune" "runtest" "-p" "merlin,dot-merlin-reader")))))))
+     (propagated-inputs (list ocaml-merlin-lib ocaml-yojson))
+     (native-inputs
+      (list ocaml-dot-merlin-reader     ; required for tests
+            ocaml-ppxlib
+            ocaml-mdx
+            jq))
+     (synopsis "Context sensitive completion for OCaml in Vim and Emacs")
+     (description "Merlin is an editor service that provides modern IDE
+features for OCaml.  Emacs and Vim support is provided out-of-the-box.
+External contributors added support for Visual Studio Code, Sublime Text and
+Atom.")
+     (license license:expat))))
+
 (define-public ocaml-gsl
   (package
     (name "ocaml-gsl")