summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-19 19:54:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-19 19:55:56 +0100
commit977403feb23d062bd073463d33c4a1fe48da6bfb (patch)
tree57c90368a66fc8bd4d170c8d90363ee0d83e3d38 /gnu
parent560df540a635e8d528e510f53b50343c6e037f6d (diff)
downloadguix-977403feb23d062bd073463d33c4a1fe48da6bfb.tar.gz
gnu: texlive-texmf: Fix build.
This is a follow-up to commit a1b4d62cda12d0d54663700a3f384f8a8ad5b13d.

* gnu/packages/tex.scm (texlive-texmf)[arguments]: Unset texlive-bin search
path.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3a3bd47267..139400cbd9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4472,6 +4472,11 @@ directly generate PDF documents instead of DVI.")
       #:phases
         (modify-phases (map (cut assq <> %standard-phases)
                             '(set-paths unpack patch-source-shebangs))
+          (add-after 'unpack 'unset-environment-variables
+            (lambda _
+              (unsetenv "TEXMF")
+              (unsetenv "TEXMFCNF")
+              #t))
           (add-after 'patch-source-shebangs 'install
             (lambda* (#:key outputs #:allow-other-keys)
               (let ((share (string-append (assoc-ref outputs "out") "/share")))