summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-06-28 08:46:49 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-10 08:26:00 +0100
commit7ee445d5a132ced3ef7a2fc7498ac5561d6380c5 (patch)
treef3a0f3c8c6f9bf79901a65818d420264acfe8669 /gnu
parentaf583ce504e089d7a64172b573e38c78ae563d23 (diff)
downloadguix-7ee445d5a132ced3ef7a2fc7498ac5561d6380c5.tar.gz
gnu: zsh-autosuggestions: Remove ruby-byebug dependency.
ruby-byebug is for Ruby 2, so it's good to move away from using it.

* gnu/packages/shellutils.scm (zsh-autosuggestions)[native-inputs]: Remove
ruby-byebug.
[arguments]: Update style.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/shellutils.scm39
1 files changed, 19 insertions, 20 deletions
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 070613afe1..cbeaa05b3d 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -188,33 +188,32 @@ in Zsh intelligently.")
     (build-system gnu-build-system)
     (native-inputs
      (list ruby
-           ruby-byebug
            ruby-pry
            ruby-rspec
            ruby-rspec-wait
            tmux
            zsh))
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-tests
-           (lambda _
-             ;; Failing tests since tmux-3.2a
-             (delete-file "spec/options/buffer_max_size_spec.rb")))
-         (delete 'configure)
-         (replace 'check ; Tests use ruby's bundler; instead execute rspec directly.
-           (lambda _
-             (setenv "TMUX_TMPDIR" (getenv "TMPDIR"))
-             (setenv "SHELL" (which "zsh"))
-             (invoke "rspec")))
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (zsh-plugins
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'patch-tests
+            (lambda _
+              ;; Failing tests since tmux-3.2a
+              (delete-file "spec/options/buffer_max_size_spec.rb")))
+          (delete 'configure)
+          (replace 'check ; Tests use ruby's bundler; instead execute rspec directly.
+            (lambda _
+              (setenv "TMUX_TMPDIR" (getenv "TMPDIR"))
+              (setenv "SHELL" (which "zsh"))
+              (invoke "rspec")))
+          (replace 'install
+            (lambda* (#:key outputs #:allow-other-keys)
+              (let* ((out (assoc-ref outputs "out"))
+                     (zsh-plugins
                       (string-append out "/share/zsh/plugins/zsh-autosuggestions")))
-               (invoke "make" "all")
-               (install-file "zsh-autosuggestions.zsh" zsh-plugins)
-               #t))))))
+                (invoke "make" "all")
+                (install-file "zsh-autosuggestions.zsh" zsh-plugins)))))))
     (home-page "https://github.com/zsh-users/zsh-autosuggestions")
     (synopsis "Fish-like autosuggestions for zsh")
     (description