summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-08 00:50:07 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-08 01:13:38 +0100
commita00543b4397c85eb1bc8142ed885aa3b50cf5ecb (patch)
tree6cdf54421942356d88efd4825975dc1f8d8bed38 /gnu
parenta1846e9b9135fe18f2418b983334f4cb7eb3df8b (diff)
downloadguix-a00543b4397c85eb1bc8142ed885aa3b50cf5ecb.tar.gz
gnu: iw: Fix cross-compilation.
* gnu/packages/linux.scm (iw)[arguments]: Rewrite as G-expression.
Replace custom code with PKG-CONFIG-FOR-TARGET, and drop the unnecessary
absolute file name altogether.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm20
1 files changed, 8 insertions, 12 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9aa4805e9a..57f6e7489c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3081,18 +3081,14 @@ configuration and monitoring interfaces.")
     (native-inputs (list pkg-config))
     (inputs (list libnl))
     (arguments
-     `(#:make-flags
-       (let* ((target ,(%current-target-system))
-              (pkg-config (if target
-                              (string-append target "-pkg-config")
-                              "pkg-config")))
-         (list
-          ,(string-append "CC=" (cc-for-target))
-          (string-append "PKG_CONFIG="
-                         (assoc-ref %build-inputs "pkg-config")
-                         "/bin/" pkg-config)
-          (string-append "PREFIX=" (assoc-ref %outputs "out"))))
-       #:phases (modify-phases %standard-phases (delete 'configure))))
+     (list #:make-flags
+           #~(list
+            (string-append "CC=" #$(cc-for-target))
+            (string-append "PKG_CONFIG=" #$(pkg-config-for-target))
+            (string-append "PREFIX=" (assoc-ref %outputs "out")))
+           #:phases
+           #~(modify-phases %standard-phases
+               (delete 'configure))))   ; no configure script
     (home-page "https://wireless.wiki.kernel.org/")
     (synopsis "Tool for configuring wireless devices")
     (description