summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-07-04 16:17:01 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-10 08:26:04 +0100
commita1e6a360a516b729c7a26864b9744f82cbb54394 (patch)
tree137fe852f5ef94c155f0ab0bb17a33f0bc8030f9 /gnu
parent3f91e3e81d65c57f345f8ba0643927f2d921299b (diff)
downloadguix-a1e6a360a516b729c7a26864b9744f82cbb54394.tar.gz
gnu: ruby-terminfo: Update to 0.2.
* gnu/packages/ruby.scm (ruby-terminfo): Update to 0.2.
[source]: Switch to source tarball.
[arguments]: Update accordingly.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm29
1 files changed, 22 insertions, 7 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 2433739750..8eff241b24 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12889,20 +12889,35 @@ about the changes.")
 (define-public ruby-terminfo
   (package
     (name "ruby-terminfo")
-    (version "0.1.1")
+    (version "0.2")
     (source
       (origin
         (method url-fetch)
-        (uri (rubygems-uri "ruby-terminfo" version))
+        (uri (string-append
+              "http://www.a-k-r.org/" name "/" name "-" version ".tar.gz"))
         (sha256
           (base32
-            "0rl4ic5pzvrpgd42z0c1s2n3j39c9znksblxxvmhkzrc0ckyg2cm"))))
+            "1n59dw351z6nzylgj0gpx4rpz6qhf8lrhzcbp1xqfpqvryhaxrjh"))))
     (build-system ruby-build-system)
     (arguments
-     `(#:test-target "test"
-       ;; Rakefile requires old packages and would need modification to
-       ;; work with current software.
-       #:tests? #f))
+     (list
+      #:test-target "test"
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'replace-git-ls-files)
+          (replace 'build
+            (lambda _
+              (invoke "ruby" "extconf.rb")
+              (invoke "make")))
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (for-each (lambda (f)
+                            (invoke "ruby" "-I" "test" f))
+                          (find-files "test" "^test_.*\\.rb$")))))
+          (replace 'install
+            (lambda _
+              (invoke "make" "install" (string-append "prefix=" #$output)))))))
     (inputs
      (list ncurses))
     (native-inputs