summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-25 18:36:05 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-25 18:36:05 +0300
commitb29742124e4d5b2c6b423b891c6c430186f10535 (patch)
tree6d09704bbe4a1fdbb84e880a04b83f72390e4f93 /gnu
parent72aba543b92c8e1a7a190f8383ea4e0ba14e9615 (diff)
downloadguix-b29742124e4d5b2c6b423b891c6c430186f10535.tar.gz
gnu: go-github-com-cespare-xxhash: Skip tests with gccgo.
* gnu/packages/syncthing.scm (go-github-com-cespare-xxhash)[arguments]:
Don't run the test suite when building with gccgo.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/syncthing.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 717a953f2f..41dd388da9 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -2,7 +2,7 @@
 ;;; Copyright © 2016 Petter <petter@mykolab.ch>
 ;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020-2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
@@ -27,6 +27,7 @@
   #:use-module (guix build-system go)
   #:use-module (guix build-system python)
   #:use-module (guix build-system trivial)
+  #:use-module (guix gexp)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
@@ -1123,7 +1124,16 @@ and RFC 5389).")
                 "12ad3z7ki9j07c4kx3ywkl6188i2afsjg7sl60wd21p6zkkpfjxq"))))
     (build-system go-build-system)
     (arguments
-     '(#:import-path "github.com/cespare/xxhash"))
+     (list
+       #:import-path "github.com/cespare/xxhash"
+       #:phases
+       #~(modify-phases %standard-phases
+           (replace 'check
+             (lambda* (#:key inputs #:allow-other-keys #:rest args)
+               (unless
+                 ;; The tests fail when run with gccgo.
+                 (false-if-exception (search-input-file inputs "/bin/gccgo"))
+                 (apply (assoc-ref %standard-phases 'check) args)))))))
     (synopsis "Go implementation of xxHash")
     (description "This package provides of Go implementation of the 64-bit
 xxHash algorithm (XXH64).")