summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-08 06:28:25 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-08 21:57:53 +0100
commitc612b619cc310a013f2a69c36fcaa0aedc38c1df (patch)
treecd7dfa4c32addc284cb2f00d208b1e876511e536 /gnu
parent7ed3e2606b1f79f23cff50eb454adb9cae10472c (diff)
downloadguix-c612b619cc310a013f2a69c36fcaa0aedc38c1df.tar.gz
gnu: tlp: Remove obsolete #t returns.
* gnu/packages/linux.scm (tlp)[arguments]:
Don't explicitly return #t from phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 22ce16a596..7b3996f770 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6956,15 +6956,13 @@ interface in sysfs, which can be accomplished with the included udev rules.")
                (setenv "TLP_SHCPL"
                        (string-append out "/share/bash-completion/completions"))
                (setenv "TLP_MAN" (string-append out "/share/man"))
-               (setenv "TLP_META" (string-append out "/share/metainfo"))
-               #t)))
+               (setenv "TLP_META" (string-append out "/share/metainfo")))))
          (add-before 'install 'fix-installation
            (lambda _
              ;; Stop the Makefile from trying to create system directories.
              (substitute* "Makefile"
                (("\\[ -f \\$\\(_CONFUSR\\) \\]") "#")
-               (("install -d -m 755 \\$\\(_VAR\\)") "#"))
-             #t))
+               (("install -d -m 755 \\$\\(_VAR\\)") "#"))))
          (replace 'install
            (lambda _ (invoke "make" "install-tlp" "install-man-tlp")))
          (add-after 'install 'wrap
@@ -7000,8 +6998,7 @@ interface in sysfs, which can be accomplished with the included udev rules.")
                                                "pciutils"
                                                "rfkill"
                                                "wireless-tools"))))))
-                         bin-files)
-               #t))))))
+                         bin-files)))))))
     (home-page "https://linrunner.de/en/tlp/tlp.html")
     (synopsis "Power management tool for Linux")
     (description "TLP is a power management tool for Linux.  It comes with