summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-12 22:08:03 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-12 22:47:56 +0100
commitc691c607d7682d08b079e4e168b9392de234b3fb (patch)
tree78910c2e5e2e5ce48c1d559f5b6dbc474cbaf0c6 /gnu
parent4dc2ecc27933a1c1f41f04ca9f3b6940f592f49b (diff)
downloadguix-c691c607d7682d08b079e4e168b9392de234b3fb.tar.gz
gnu: Add r-dorng.
* gnu/packages/cran.scm (r-dorng): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5bd5c60d49..67a1950756 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10839,3 +10839,32 @@ using @code{S3}.")
 for model selection.  The calibration methods available are based on the slope
 heuristics.")
     (license license:gpl2+)))
+
+(define-public r-dorng
+  (package
+    (name "r-dorng")
+    (version "1.7.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "doRNG" version))
+       (sha256
+        (base32
+         "1sb75aqkliprglfxc4x4wds6alqgzhvl2n812g1d32a88ra3slr7"))))
+    (properties `((upstream-name . "doRNG")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-foreach" ,r-foreach)
+       ("r-iterators" ,r-iterators)
+       ("r-pkgmaker" ,r-pkgmaker)
+       ("r-rngtools" ,r-rngtools)))
+    (home-page "https://renozao.github.io/doRNG/")
+    (synopsis "Generic reproducible parallel backend for foreach loops")
+    (description
+     "This package provides functions to perform reproducible parallel
+@code{foreach} loops, using independent random streams as generated by
+L'Ecuyer's combined multiple-recursive generator.  It enables to easily
+convert standard @code{%dopar%} loops into fully reproducible loops,
+independently of the number of workers, the task scheduling strategy, or the
+chosen parallel environment and associated foreach backend.")
+    (license license:gpl2+)))