summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:11 +0200
commitd129d962e437fd215c5e9428fc1b26e2d72ffbda (patch)
tree141ad3a8a018e9d66b26275699d064e803d5f32e /gnu
parent578d1b6374df8f5f0239f62409e326ae138acd15 (diff)
downloadguix-d129d962e437fd215c5e9428fc1b26e2d72ffbda.tar.gz
gnu: breezy: Update to 3.2.2.
* gnu/packages/version-control.scm (breezy): Update to 3.2.2.
[inputs]: Add python-fastbencode.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/version-control.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 5badc28fc5..9d0786d2d9 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -11,7 +11,7 @@
 ;;; Copyright © 2015, 2017, 2018, 2020 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2016, 2017, 2018 Nikita <nikita@n0.is>
-;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017–2022 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
 ;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2017, 2020 EuAndreh <eu@euandre.org>
@@ -180,7 +180,7 @@ as well as the classic centralized workflow.")
 (define-public breezy
   (package
     (name "breezy")
-    (version "3.2.1")
+    (version "3.2.2")
     (source
      (origin
        (method url-fetch)
@@ -188,14 +188,14 @@ as well as the classic centralized workflow.")
                            (version-major+minor version) "/" version
                            "/+download/breezy-" version ".tar.gz"))
        (sha256
-        (base32
-         "0p6q545xpmxa6fgvkjglfpqpybg33817vhw0a82az8i83bmnicp0"))))
+        (base32 "1md4b6ajawf5h50fqizmjj0g833ihc674dh7fn0mvl4d412nwyhq"))))
     (build-system python-build-system)
     ;; TODO: Maybe regenerate C files with Cython?
     (inputs
      `(("gettext" ,gettext-minimal)
        ("python-configobj" ,python-configobj)
        ("python-dulwich" ,python-dulwich)
+       ("python-fastbencode" ,python-fastbencode)
        ("python-fastimport" ,python-fastimport)
        ("python-paramiko" ,python-paramiko)
        ("python-patiencediff" ,python-patiencediff)