summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2022-05-23 22:37:26 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-05-25 09:27:25 +0200
commitdab819d5c4c55609efae098c8e3c2f2757c34e5b (patch)
tree43691e8653b203da8cd5100085f67253ce48f2a7 /gnu
parentd129d962e437fd215c5e9428fc1b26e2d72ffbda (diff)
downloadguix-dab819d5c4c55609efae098c8e3c2f2757c34e5b.tar.gz
Move (gnu platform) and (gnu platforms ...) to guix/.
* gnu/platform.scm:
* gnu/platforms/arm.scm:
* gnu/platforms/hurd.scm:
* gnu/platforms/mips.scm:
* gnu/platforms/powerpc.scm:
* gnu/platforms/riscv.scm:
* gnu/platforms/s390.scm:
* gnu/platforms/x86.scm: Move to guix/.

* Makefile.am:
* doc/guix.texi (Porting to a New Platform):
* etc/release-manifest.scm:
* gnu/ci.scm:
* gnu/image.scm:
* gnu/local.mk:
* gnu/packages/bioinformatics.scm:
* gnu/packages/bootstrap.scm:
* gnu/packages/cross-base.scm:
* gnu/packages/instrumentation.scm:
* gnu/packages/linux.scm:
* gnu/system/image.scm:
* gnu/system/images/hurd.scm:
* gnu/system/images/novena.scm:
* gnu/system/images/pine64.scm:
* gnu/system/images/pinebook-pro.scm:
* gnu/system/images/rock64.scm:
* guix/scripts/build.scm:
* guix/scripts/system.scm:
* guix/self.scm: Update (gnu platform...) to (guix platform...).

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/ci.scm2
-rw-r--r--gnu/image.scm2
-rw-r--r--gnu/local.mk8
-rw-r--r--gnu/packages/bioinformatics.scm2
-rw-r--r--gnu/packages/bootstrap.scm2
-rw-r--r--gnu/packages/cross-base.scm2
-rw-r--r--gnu/packages/instrumentation.scm2
-rw-r--r--gnu/packages/linux.scm2
-rw-r--r--gnu/platform.scm139
-rw-r--r--gnu/platforms/arm.scm38
-rw-r--r--gnu/platforms/hurd.scm29
-rw-r--r--gnu/platforms/mips.scm30
-rw-r--r--gnu/platforms/powerpc.scm38
-rw-r--r--gnu/platforms/riscv.scm30
-rw-r--r--gnu/platforms/s390.scm30
-rw-r--r--gnu/platforms/x86.scm59
-rw-r--r--gnu/system/image.scm2
-rw-r--r--gnu/system/images/hurd.scm2
-rw-r--r--gnu/system/images/novena.scm2
-rw-r--r--gnu/system/images/pine64.scm2
-rw-r--r--gnu/system/images/pinebook-pro.scm2
-rw-r--r--gnu/system/images/rock64.scm2
22 files changed, 13 insertions, 414 deletions
diff --git a/gnu/ci.scm b/gnu/ci.scm
index 9de1b54fc8..f476e22731 100644
--- a/gnu/ci.scm
+++ b/gnu/ci.scm
@@ -55,7 +55,7 @@
   #:use-module (gnu packages multiprecision)
   #:use-module (gnu packages make-bootstrap)
   #:use-module (gnu packages package-management)
-  #:use-module (gnu platform)
+  #:use-module (guix platform)
   #:use-module (gnu system)
   #:use-module (gnu system image)
   #:use-module (gnu system vm)
diff --git a/gnu/image.scm b/gnu/image.scm
index 0b3a5a096b..e10a495d3d 100644
--- a/gnu/image.scm
+++ b/gnu/image.scm
@@ -17,7 +17,7 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu image)
-  #:use-module (gnu platform)
+  #:use-module (guix platform)
   #:use-module (guix records)
   #:export (partition
             partition?
diff --git a/gnu/local.mk b/gnu/local.mk
index 06826ee0cc..a4250248ca 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -89,7 +89,6 @@ GNU_SYSTEM_MODULES =				\
   %D%/home/services/utils.scm			\
   %D%/home/services/xdg.scm			\
   %D%/image.scm					\
-  %D%/platform.scm				\
   %D%/packages.scm				\
   %D%/packages/abduco.scm			\
   %D%/packages/abiword.scm			\
@@ -631,13 +630,6 @@ GNU_SYSTEM_MODULES =				\
   %D%/packages/zile.scm				\
   %D%/packages/zwave.scm			\
 						\
-  %D%/platforms/arm.scm		                \
-  %D%/platforms/mips.scm	                \
-  %D%/platforms/powerpc.scm	                \
-  %D%/platforms/riscv.scm	                \
-  %D%/platforms/s390.scm	                \
-  %D%/platforms/x86.scm		                \
-						\
   %D%/services.scm				\
   %D%/services/admin.scm			\
   %D%/services/audio.scm                        \
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 2a312b1989..474d85f320 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -161,7 +161,7 @@
   #:use-module (gnu packages wget)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg)
-  #:use-module (gnu platform)
+  #:use-module (guix platform)
   #:use-module (srfi srfi-1)
   #:use-module (srfi srfi-26)
   #:use-module (ice-9 match))
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 5337617a53..d2914fb5a7 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -26,7 +26,7 @@
 (define-module (gnu packages bootstrap)
   #:use-module (guix licenses)
   #:use-module (gnu packages)
-  #:use-module (gnu platform)
+  #:use-module (guix platform)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system)
diff --git a/gnu/packages/cross-base.scm b/gnu/packages/cross-base.scm
index 427fefbcd2..93e4f8a445 100644
--- a/gnu/packages/cross-base.scm
+++ b/gnu/packages/cross-base.scm
@@ -30,7 +30,7 @@
   #:use-module (gnu packages linux)
   #:use-module (gnu packages hurd)
   #:use-module (gnu packages mingw)
-  #:use-module (gnu platform)
+  #:use-module (guix platform)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix utils)
diff --git a/gnu/packages/instrumentation.scm b/gnu/packages/instrumentation.scm
index c5062388f8..2db21aef1b 100644
--- a/gnu/packages/instrumentation.scm
+++ b/gnu/packages/instrumentation.scm
@@ -42,7 +42,7 @@
   #:use-module (gnu packages swig)
   #:use-module (gnu packages tbb)
   #:use-module (gnu packages xml)
-  #:use-module (gnu platform)
+  #:use-module (guix platform)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system copy)
   #:use-module (guix build-system gnu)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 048fdcec98..bd24fce432 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -158,7 +158,7 @@
   #:use-module (gnu packages groff)
   #:use-module (gnu packages selinux)
   #:use-module (gnu packages swig)
-  #:use-module (gnu platform)
+  #:use-module (guix platform)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system copy)
   #:use-module (guix build-system gnu)
diff --git a/gnu/platform.scm b/gnu/platform.scm
deleted file mode 100644
index fdc3685e7c..0000000000
--- a/gnu/platform.scm
+++ /dev/null
@@ -1,139 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu platform)
-  #:use-module (guix discovery)
-  #:use-module (guix memoization)
-  #:use-module (guix records)
-  #:use-module (guix ui)
-  #:use-module (srfi srfi-1)
-  #:export (platform
-            platform?
-            platform-target
-            platform-system
-            platform-linux-architecture
-            platform-glibc-dynamic-linker
-
-            platform-modules
-            platforms
-            lookup-platform-by-system
-            lookup-platform-by-target
-            lookup-platform-by-target-or-system
-            platform-system->target
-            platform-target->system
-
-            systems
-            targets))
-
-
-;;;
-;;; Platform record.
-;;;
-
-;; Description of a platform supported by GNU Guix.
-;;
-;; The 'target' field must be a valid GNU triplet as defined here:
-;; https://www.gnu.org/software/autoconf/manual/autoconf-2.68/html_node/Specifying-Target-Triplets.html.
-;; It is used for cross-compilation purposes.
-;;
-;; The 'system' field is the name of the corresponding system as defined in
-;; the (gnu packages bootstrap) module.  It can be for instance
-;; "aarch64-linux" or "armhf-linux".  It is used to emulate a different host
-;; architecture, for instance i686-linux on x86_64-linux-gnu, or armhf-linux
-;; on x86_64-linux, using the QEMU binfmt transparent emulation mechanism.
-;;
-;; The 'linux-architecture' is only relevant if the kernel is Linux.  In that
-;; case, it corresponds to the ARCH variable used when building Linux.
-;;
-;; The 'glibc-dynamic-linker' field is the name of Glibc's dynamic linker for
-;; the corresponding system.
-(define-record-type* <platform> platform make-platform
-  platform?
-  (target               platform-target)
-  (system               platform-system)
-  (linux-architecture   platform-linux-architecture
-                        (default #f))
-  (glibc-dynamic-linker platform-glibc-dynamic-linker))
-
-
-;;;
-;;; Platforms.
-;;;
-
-(define (platform-modules)
-  "Return the list of platform modules."
-  (all-modules (map (lambda (entry)
-                      `(,entry . "gnu/platforms"))
-                    %load-path)
-               #:warn warn-about-load-error))
-
-(define platforms
-  ;; The list of publically-known platforms.
-  (memoize
-   (lambda ()
-     (fold-module-public-variables (lambda (obj result)
-                                     (if (platform? obj)
-                                         (cons obj result)
-                                         result))
-                                   '()
-                                   (platform-modules)))))
-
-(define (lookup-platform-by-system system)
-  "Return the platform corresponding to the given SYSTEM."
-  (find (lambda (platform)
-          (let ((s (platform-system platform)))
-            (and (string? s) (string=? s system))))
-        (platforms)))
-
-(define (lookup-platform-by-target target)
-  "Return the platform corresponding to the given TARGET."
-  (find (lambda (platform)
-          (let ((t (platform-target platform)))
-            (and (string? t) (string=? t target))))
-        (platforms)))
-
-(define (lookup-platform-by-target-or-system target-or-system)
-  "Return the platform corresponding to the given TARGET or SYSTEM."
-  (or (lookup-platform-by-target target-or-system)
-      (lookup-platform-by-system target-or-system)))
-
-(define (platform-system->target system)
-  "Return the target matching the given SYSTEM if it exists or false
-otherwise."
-  (let ((platform (lookup-platform-by-system system)))
-    (and=> platform platform-target)))
-
-(define (platform-target->system target)
-  "Return the system matching the given TARGET if it exists or false
-otherwise."
-  (let ((platform (lookup-platform-by-target system)))
-    (and=> platform platform-system)))
-
-
-;;;
-;;; Systems & Targets.
-;;;
-
-(define (systems)
-  "Return the list of supported systems."
-  (delete-duplicates
-   (filter-map platform-system (platforms))))
-
-(define (targets)
-  "Return the list of supported targets."
-  (map platform-target (platforms)))
diff --git a/gnu/platforms/arm.scm b/gnu/platforms/arm.scm
deleted file mode 100644
index bf68b2d00f..0000000000
--- a/gnu/platforms/arm.scm
+++ /dev/null
@@ -1,38 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu platforms arm)
-  #:use-module (gnu platform)
-  #:use-module (gnu packages linux)
-  #:use-module (guix records)
-  #:export (armv7-linux
-            aarch64-linux))
-
-(define armv7-linux
-  (platform
-   (target "arm-linux-gnueabihf")
-   (system "armhf-linux")
-   (linux-architecture "arm")
-   (glibc-dynamic-linker "/lib/ld-linux-armhf.so.3")))
-
-(define aarch64-linux
-  (platform
-   (target "aarch64-linux-gnu")
-   (system "aarch64-linux")
-   (linux-architecture "arm64")
-   (glibc-dynamic-linker "/lib/ld-linux-aarch64.so.1")))
diff --git a/gnu/platforms/hurd.scm b/gnu/platforms/hurd.scm
deleted file mode 100644
index 328e9818ad..0000000000
--- a/gnu/platforms/hurd.scm
+++ /dev/null
@@ -1,29 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu platforms hurd)
-  #:use-module (gnu platform)
-  #:use-module (gnu packages linux)
-  #:use-module (guix records)
-  #:export (hurd))
-
-(define hurd
-  (platform
-   (target "i586-pc-gnu")
-   (system "i586-gnu")
-   (glibc-dynamic-linker "/lib/ld.so.1")))
diff --git a/gnu/platforms/mips.scm b/gnu/platforms/mips.scm
deleted file mode 100644
index 174657da13..0000000000
--- a/gnu/platforms/mips.scm
+++ /dev/null
@@ -1,30 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu platforms mips)
-  #:use-module (gnu platform)
-  #:use-module (gnu packages linux)
-  #:use-module (guix records)
-  #:export (mips64-linux))
-
-(define mips64-linux
-  (platform
-   (target "mips64el-linux-gnu")
-   (system "mips64el-linux")
-   (linux-architecture "mips")
-   (glibc-dynamic-linker "/lib/ld.so.1")))
diff --git a/gnu/platforms/powerpc.scm b/gnu/platforms/powerpc.scm
deleted file mode 100644
index 1d0b5cb666..0000000000
--- a/gnu/platforms/powerpc.scm
+++ /dev/null
@@ -1,38 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu platforms powerpc)
-  #:use-module (gnu platform)
-  #:use-module (gnu packages linux)
-  #:use-module (guix records)
-  #:export (powerpc-linux
-            powerpc64le-linux))
-
-(define powerpc-linux
-  (platform
-   (target "powerpc-linux-gnu")
-   (system "powerpc-linux")
-   (linux-architecture "powerpc")
-   (glibc-dynamic-linker "/lib/ld.so.1")))
-
-(define powerpc64le-linux
-  (platform
-   (target "powerpc64le-linux-gnu")
-   (system "powerpc64le-linux")
-   (linux-architecture "powerpc")
-   (glibc-dynamic-linker "/lib/ld64.so.2")))
diff --git a/gnu/platforms/riscv.scm b/gnu/platforms/riscv.scm
deleted file mode 100644
index c2b4850e55..0000000000
--- a/gnu/platforms/riscv.scm
+++ /dev/null
@@ -1,30 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu platforms riscv)
-  #:use-module (gnu platform)
-  #:use-module (gnu packages linux)
-  #:use-module (guix records)
-  #:export (riscv64-linux))
-
-(define riscv64-linux
-  (platform
-   (target "riscv64-linux-gnu")
-   (system "riscv64-linux")
-   (linux-architecture "riscv")
-   (glibc-dynamic-linker "/lib/ld-linux-riscv64-lp64d.so.1")))
diff --git a/gnu/platforms/s390.scm b/gnu/platforms/s390.scm
deleted file mode 100644
index d3b1133974..0000000000
--- a/gnu/platforms/s390.scm
+++ /dev/null
@@ -1,30 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu platforms s390)
-  #:use-module (gnu platform)
-  #:use-module (gnu packages linux)
-  #:use-module (guix records)
-  #:export (s390x-linux))
-
-(define s390x-linux
-  (platform
-   (target "s390x-linux-gnu")
-   (system "s390x-linux")
-   (linux-architecture "s390")
-   (glibc-dynamic-linker "/lib/ld64.so.1")))
diff --git a/gnu/platforms/x86.scm b/gnu/platforms/x86.scm
deleted file mode 100644
index fba7dd4fc0..0000000000
--- a/gnu/platforms/x86.scm
+++ /dev/null
@@ -1,59 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu platforms x86)
-  #:use-module (gnu platform)
-  #:use-module (gnu packages linux)
-  #:use-module (guix records)
-  #:export (i686-linux
-            x86_64-linux
-            i686-mingw
-            x86_64-mingw
-            hurd))
-
-(define i686-linux
-  (platform
-   (target "i686-linux-gnu")
-   (system "i686-linux")
-   (linux-architecture "i386")
-   (glibc-dynamic-linker "/lib/ld-linux.so.2")))
-
-(define x86_64-linux
-  (platform
-   (target "x86_64-linux-gnu")
-   (system "x86_64-linux")
-   (linux-architecture "x86_64")
-   (glibc-dynamic-linker "/lib/ld-linux-x86-64.so.2")))
-
-(define i686-mingw
-  (platform
-   (target "i686-w64-mingw32")
-   (system #f)
-   (glibc-dynamic-linker #f)))
-
-(define x86_64-mingw
-  (platform
-   (target "x86_64-w64-mingw32")
-   (system #f)
-   (glibc-dynamic-linker #f)))
-
-(define hurd
-  (platform
-   (target "i586-pc-gnu")
-   (system "i586-gnu")
-   (glibc-dynamic-linker "/lib/ld.so.1")))
diff --git a/gnu/system/image.scm b/gnu/system/image.scm
index 74b81d02f6..dd32e58c2d 100644
--- a/gnu/system/image.scm
+++ b/gnu/system/image.scm
@@ -32,7 +32,7 @@
   #:use-module (gnu bootloader)
   #:use-module (gnu bootloader grub)
   #:use-module (gnu image)
-  #:use-module (gnu platform)
+  #:use-module (guix platform)
   #:use-module (gnu services)
   #:use-module (gnu services base)
   #:use-module (gnu system)
diff --git a/gnu/system/images/hurd.scm b/gnu/system/images/hurd.scm
index 4c38c46a89..36b6f3a200 100644
--- a/gnu/system/images/hurd.scm
+++ b/gnu/system/images/hurd.scm
@@ -23,7 +23,7 @@
   #:use-module (gnu bootloader grub)
   #:use-module (gnu image)
   #:use-module (gnu packages ssh)
-  #:use-module (gnu platforms hurd)
+  #:use-module (guix platforms hurd)
   #:use-module (gnu services)
   #:use-module (gnu services ssh)
   #:use-module (gnu system)
diff --git a/gnu/system/images/novena.scm b/gnu/system/images/novena.scm
index 5b625e56c5..b9ff6dcfea 100644
--- a/gnu/system/images/novena.scm
+++ b/gnu/system/images/novena.scm
@@ -22,7 +22,7 @@
   #:use-module (gnu bootloader u-boot)
   #:use-module (gnu image)
   #:use-module (gnu packages linux)
-  #:use-module (gnu platforms arm)
+  #:use-module (guix platforms arm)
   #:use-module (gnu services)
   #:use-module (gnu services base)
   #:use-module (gnu system)
diff --git a/gnu/system/images/pine64.scm b/gnu/system/images/pine64.scm
index aaec458766..99c4ed6ceb 100644
--- a/gnu/system/images/pine64.scm
+++ b/gnu/system/images/pine64.scm
@@ -21,7 +21,7 @@
   #:use-module (gnu bootloader u-boot)
   #:use-module (gnu image)
   #:use-module (gnu packages linux)
-  #:use-module (gnu platforms arm)
+  #:use-module (guix platforms arm)
   #:use-module (gnu services)
   #:use-module (gnu services base)
   #:use-module (gnu system)
diff --git a/gnu/system/images/pinebook-pro.scm b/gnu/system/images/pinebook-pro.scm
index 1bfac7a8bb..7e8910427e 100644
--- a/gnu/system/images/pinebook-pro.scm
+++ b/gnu/system/images/pinebook-pro.scm
@@ -21,7 +21,7 @@
   #:use-module (gnu bootloader u-boot)
   #:use-module (gnu image)
   #:use-module (gnu packages linux)
-  #:use-module (gnu platforms arm)
+  #:use-module (guix platforms arm)
   #:use-module (gnu services)
   #:use-module (gnu services base)
   #:use-module (gnu system)
diff --git a/gnu/system/images/rock64.scm b/gnu/system/images/rock64.scm
index d25d55e528..68cb65f115 100644
--- a/gnu/system/images/rock64.scm
+++ b/gnu/system/images/rock64.scm
@@ -21,7 +21,7 @@
   #:use-module (gnu bootloader u-boot)
   #:use-module (gnu image)
   #:use-module (gnu packages linux)
-  #:use-module (gnu platforms arm)
+  #:use-module (guix platforms arm)
   #:use-module (gnu services)
   #:use-module (gnu services base)
   #:use-module (gnu services networking)