summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-13 14:26:08 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-13 14:26:08 +0100
commitf313baf0c890f69bf2db6ee9a9934024edb81f09 (patch)
tree602fe638296e9bf2bb61aa5d26a1852f881871a0 /gnu
parent9475a248fcceaaf12733e24aeaa4c9f8cef1cec0 (diff)
downloadguix-f313baf0c890f69bf2db6ee9a9934024edb81f09.tar.gz
gnu: Add r-pbdzmq.
* gnu/packages/cran.scm (r-pbdzmq): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index cebc92a627..2702e62a9a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -58,6 +58,7 @@
   #:use-module (gnu packages maths)
   #:use-module (gnu packages mpi)
   #:use-module (gnu packages multiprecision)
+  #:use-module (gnu packages networking)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
@@ -11522,3 +11523,31 @@ also provides tools for efficient random number generation and graphics.")
 boxplot/stripchart/violin plots.  It can be used to plot univariate comparison
 graphs.")
     (license license:gpl2)))
+
+(define-public r-pbdzmq
+  (package
+    (name "r-pbdzmq")
+    (version "0.3-3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "pbdZMQ" version))
+       (sha256
+        (base32
+         "1jkfcfhspvqra7vbllrvkz3jx8j7d0ang6zzcdjgpb7200sc29mf"))))
+    (properties `((upstream-name . "pbdZMQ")))
+    (build-system r-build-system)
+    (inputs
+     `(("zeromq" ,zeromq)
+       ("zlib" ,zlib)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://pbdr.org/")
+    (synopsis "R interface to ZeroMQ")
+    (description
+     "ZeroMQ is a well-known library for high-performance asynchronous
+messaging in scalable, distributed applications.  This package provides high
+level R wrapper functions to easily utilize ZeroMQ.  The main focus is on
+interactive client/server programming frameworks.  A few wrapper functions
+compatible with @code{rzmq} are also provided.")
+    (license license:gpl3)))