summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRyan Prior <rprior@protonmail.com>2020-10-12 03:50:09 +0000
committerLudovic Courtès <ludo@gnu.org>2020-10-27 18:00:28 +0100
commit00c0bfd4f70f5e3fa8abf36fbd436fc9399ae9ff (patch)
tree1f96b61c5b530017d8ceaca47a8b284a6d5483b0 /gnu
parent560eec4010f6302e2e3ec270536646ca0e12436c (diff)
downloadguix-00c0bfd4f70f5e3fa8abf36fbd436fc9399ae9ff.tar.gz
gnu: go-github-com-google-go-cmp-cmp: Update to 0.5.2.
* gnu/packages/golang.scm: (go-github-com-google-go-cmp-cmp): Update to 0.5.2.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 648e8cfba4..27ba822fb7 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3993,7 +3993,7 @@ colorized or SGR defined output to the standard output.")
 (define-public go-github-com-google-go-cmp-cmp
   (package
     (name "go-github-com-google-go-cmp-cmp")
-    (version "0.3.1")
+    (version "0.5.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -4002,11 +4002,13 @@ colorized or SGR defined output to the standard output.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1caw49i0plkjxir7kdf5qhwls3krqwfmi7g4h392rdfwi3kfahx1"))))
+                "0qchy411jm9q2l9mf7x3ry2ycaqp9xdhf2nx14qrpzcxfigv2705"))))
     (build-system go-build-system)
     (arguments
      '(#:import-path "github.com/google/go-cmp/cmp"
        #:unpack-path "github.com/google/go-cmp"))
+    (propagated-inputs
+     `(("go-golang-org-x-xerrors" ,go-golang-org-x-xerrors)))
     (synopsis "Determine equality of values in Go")
     (description "This package provides a more powerful and safer
 alternative to @code{reflect.DeepEqual} for comparing whether two values